Sony DVP-S360 is junk!!

Discussion in 'Archived Threads 2001-2004' started by BrentPollard, Oct 21, 2002.

  1. BrentPollard

    BrentPollard Second Unit

    Joined:
    Dec 18, 2001
    Messages:
    445
    Likes Received:
    0
    I purchased said unit as a boxing day special X-mas 2000 and fortunately got extended warranty at the same. I say fortunately because it is going in for it's 3rd visit to the repair shop for the same issue (13:00 error). As the warranty expires this Dec I am moving up the corporate food chain, via e-mail and phone conversations I am negotiating for a completely new model, I'm hoping to throw in a few bucks and get an ES model. Doing a search the first time it crashed I learned that this unit has problems but has anybody here had 3 crashes? I'll keep you posted as to how things turn out .[​IMG]
     
  2. jeff lam

    jeff lam Screenwriter

    Joined:
    Jun 4, 2001
    Messages:
    1,798
    Likes Received:
    0
    Location:
    San Jose, CA
    Real Name:
    Jeff Lam
    The 360 and 560 players were know to have these problems. I used to have this problem with my 560 as it would freeze and skip back a couple chapters on its own. Never really had the 13:00 problem except a couple times, but after ejecting the disc and putting it back in again it worked fine. For some reason it would skip around when I played audio cd's on it. When I got my CD changer, it didn't do it anymore. Could just be coincidence. They also have trouble reading badly scratched discs.
     
  3. BrentPollard

    BrentPollard Second Unit

    Joined:
    Dec 18, 2001
    Messages:
    445
    Likes Received:
    0
    I agree on the scratched disc comment. It almost always occurs with rental or used copies. Most of my pristine copies play just fine but I do rent quite a bit and it is annoying. My friend got his of the same stack the same day as I did and his has performed flawlessly. I guess I got one of the lemons.[​IMG]
     
  4. Mark Zimmer

    Mark Zimmer Producer

    Joined:
    Jun 30, 1997
    Messages:
    4,300
    Likes Received:
    40
    If you look at audioreview.com (I think), you'll find posts from hundreds of unhappy S360 owners afflicted with the 13:00 problem. Mine got it and died, permanently. Even the recalibrating trick wouldn't revive it.
     
  5. BrentPollard

    BrentPollard Second Unit

    Joined:
    Dec 18, 2001
    Messages:
    445
    Likes Received:
    0
    Yeah I read those forums when I took it in the first time. I made it quite clear that an exchange for a better model is my main objctive.[​IMG] The frind I mentioned in the first post has connections fairly high up as he was a Store manager for sveral years so hopfully I'll get this sorted out this time.
     
  6. hwshi

    hwshi Stunt Coordinator

    Joined:
    Aug 5, 2000
    Messages:
    131
    Likes Received:
    0
    funny this should get posted today as i just gave up on mine last night.damn thing can no longer go through an entire movie without glitches,freezes,jumps......
    so am in the market for a new player as of today,unfortunatly the one i have my eye on was sold out.panny rp82.the other model in the same price range/features was the sony 715. think i will go with the panny this time round.
     
  7. Steve_AA

    Steve_AA Agent

    Joined:
    Jan 24, 2002
    Messages:
    45
    Likes Received:
    0
    I guess my S360 is one of the lucky ones. Bought it July 2000 and haven't had one glitch, skip or the 13:00 problem. I saw the same problem comments over at that site last fall and have been waiting for my unit to fail so I could have an excuse to upgrade. [​IMG] But, the damn thing just keeps chuggin' along playing everything I put into it just fine. I should be so lucky with my next player.
     
  8. Martin Fontaine

    Martin Fontaine Supporting Actor

    Joined:
    Aug 15, 2001
    Messages:
    626
    Likes Received:
    0
    I'm with steve on this one, got mine in July 2000 and worked fine, I guess a firmware upgrade that the units in later 2000 had a bug...

    The only little problems I had are isolated incidents, nothing to worry about. Once after pressing Pause and then a few seconds later Stop, instead of displaying the jacket picture in the background, the still image just got into "Anamorphic Mode" but as soon as I pressed Play, it resumed fine. And another one, yesterday, when I rewind for a few seconds then press play again it took a few seconds (2 or 3 at most) before it resumed... That is the only time it did that so I'm not worried... It's been a fine player for the 2 and a half years it served me.
     
  9. JohnBrianW.

    JohnBrianW. Stunt Coordinator

    Joined:
    Aug 21, 2002
    Messages:
    156
    Likes Received:
    0
    What is the 13:00 problem? My tray won't open anyomore and I'm going to go to battle with Future Shop this weekend and then probably onto Sony.
     
  10. BrentPollard

    BrentPollard Second Unit

    Joined:
    Dec 18, 2001
    Messages:
    445
    Likes Received:
    0
    13:00 shows up in the display when it won't read a disc. That's all I can really tell ya.
    I had forgotten about this thread, well I didn't get a replacement they fixed my unit yet again, so I calmly told them that I have purchased a lot of product from them (Many of the salesmen remark as such when they bring up my info on the computer), and the next time I have to bring it in that will be the last time they see me. [​IMG]
     
  11. Phil_O

    Phil_O Stunt Coordinator

    Joined:
    Feb 10, 2002
    Messages:
    135
    Likes Received:
    0
    Mine just died, straight up. Stopped recognizing discs of any sort. [​IMG]
     

Share This Page