Private message help!

Discussion in 'Archived Threads 2001-2004' started by cafink, Nov 26, 2001.

  1. cafink

    cafink Producer

    Joined:
    Apr 19, 1999
    Messages:
    3,043
    Likes Received:
    37
    Trophy Points:
    0
    Real Name:
    Carl Fink
    When I logged on to the forum just a few moments ago, I noticed the following message:

     
  2. cafink

    cafink Producer

    Joined:
    Apr 19, 1999
    Messages:
    3,043
    Likes Received:
    37
    Trophy Points:
    0
    Real Name:
    Carl Fink
    Well, I just got it to work, though I'm not quite sure what I did!
     
  3. Iain Lambert

    Iain Lambert Screenwriter

    Joined:
    Jun 7, 1999
    Messages:
    1,345
    Likes Received:
    0
    Trophy Points:
    0
    I've got the same at the moment. Dan Brecher sent me a message on Friday, and while it doesn't show up in the messages in the last year, I can see it if I look at messages since 'the beginning'. So it looks like there is a date quirk in the private messages section.
     
  4. Parker Clack

    Parker Clack Schizophrenic Man
    Moderator

    Joined:
    Jun 30, 1997
    Messages:
    12,216
    Likes Received:
    59
    Trophy Points:
    9,110
    Location:
    Kansas City, MO
    Real Name:
    Parker
    Gentlemen:

    You need to go to the User Control panel and click on Edit Options and then set the timezone for the forum to your local time zone. Since the default is to show you all messages from the last year I am not sure why you are not seeing messages that have been sent to you. But try setting your local timezone and see what happens.

    Also, make sure that you are looking at your Inbox and not your sent messages, etc.

    Parker
     
  5. Iain Lambert

    Iain Lambert Screenwriter

    Joined:
    Jun 7, 1999
    Messages:
    1,345
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the tip Parker, but I've checked it and its set to GMT, just as it should be. I can't see either the message in my inbox or the recipt in my outbox unless I switch the 'since' field to 'the beginning' rather than just 'the last year'. The dates marked by the messages are correct, though.

    What database do you use on the backend, by the way? If I had to guess at a cause, I'd lay the finger of suspicion at it thinking the message is in the future, so it might be a bug in the time compare code. Mind you, it seems to work fine for the main forums, so thats probably not it.

    Oh, and as this marks my 2000th post thanks for doing such a great job with the site; as the post count suggests I rather like it here!
     
  6. Parker Clack

    Parker Clack Schizophrenic Man
    Moderator

    Joined:
    Jun 30, 1997
    Messages:
    12,216
    Likes Received:
    59
    Trophy Points:
    9,110
    Location:
    Kansas City, MO
    Real Name:
    Parker
    Iain:

    First off. Congrats on the 2000th. Sorry it had to be about a problem with the software.

    We use MySQL as the database backend. I am not sure why you are having this problem. It is the first that I have heard of lately. I think that Carl had a problem with it initially but then this resolved. You should be able to see any message written to you in the private area within the last year. It doesn't make any sense that it works ok for me on my end using IE, Netscape and Opera on 98, ME and XP.

    I try setting it to view the last 10 days by default and see if that helps.

    Parker
     
  7. Iain Lambert

    Iain Lambert Screenwriter

    Joined:
    Jun 7, 1999
    Messages:
    1,345
    Likes Received:
    0
    Trophy Points:
    0
    Thanks Parker. As I said in my test reply back to you, the original message still doesn't show up unless I view since 'the beginning', but your new message is working fine. MySQL isn't what I was thinking of with the database problem though, so my longshot of a guess was out.

    The fact that its working again means that its no biggie either, so I wouldn't stress over it.

    oh, and I'm on IE 5.5 sp 2 under Windows 2000, if its something client-side thats causing the problem.
     

Share This Page