What's new

Help with Denon 4800 Receiver please! (1 Viewer)

James Bergeron

Supporting Actor
Joined
Oct 9, 2001
Messages
831
Hi all.

I am hoping someone here can help -- I am pulling my hair out!

I cannot get on the on screen display to work on my Denon 4800 receiver, so I can't setup anything on the receiver. Lucky for me everything is pretty much setup but I wanted to change a few things but I can't get the screen up.

I realize the screen only comes up on composite or s-video on monitor 1 output. I tried both with 2 different display devices (projector and lcd tv) no luck. I tried plugging in a dvd player into vcr-2 then using the composite to output the video to my projector and that works, so the pass-through video is working... therefore the connector / cables are good.

But I can hit that "on screen" or "setup" button on the remote all I want and I cannot get that screen up for the life of me. I was thinking maybe a hard reset back to factory could solve it -- but I can't figure out how to do that any ideas?

And if the factory reset doesn't get the screen back for me, then I'm really pooched because none of my settings will be right!
 

Ed Moxley

Senior HTF Member
Joined
May 25, 2003
Messages
2,701
Location
Eastern NC
Real Name
Ed
This is in the trouble shooting page of the manual (Pg. 60)

The on screen display is not displayed. • “On screen display” is set to off on the
system setup menu screen.
• Set “on screen display” on the system
setup menu screen to on.

In case you don't have the manual, get it here:
http://www.usa.denon.com/avr4800_ownersmanual.pdf
If nothing else, it should tell you how to reset to factory settings.
Good luck!
htf_images_smilies_smile.gif
 

James Bergeron

Supporting Actor
Joined
Oct 9, 2001
Messages
831
Unfortunately it doesn't say how to reset (at least I can't find it in there) and yes I checked that troubleshooting.

That is for the "volume" and other such functions when normally using the device. To turn on or off the "onscreen display" you have to actually get to the onscreen display. Which isn't showing up. Either the video driver in my unit is fried or something else is wonky. It seems like it isn't accepting the remote input (and I tried 2 remotes).

EDIT: I did find out how to reset to defaults using the PDF thanks for that. Searching the paper copy I couldn't find it for the life of me.
 

James Bergeron

Supporting Actor
Joined
Oct 9, 2001
Messages
831
Well in case anyone is wondering. A reset didn't work and now I'm basically hosed. :frowning:

Ah well time to upgrade I guess. I will first be looking into repair work but I don't have my hopes up.
 

Users who are viewing this thread

Forum statistics

Threads
356,525
Messages
5,115,177
Members
144,106
Latest member
linda19798888
Recent bookmarks
0
Top