denon protection circuit question

Discussion in 'AV Receivers' started by Bob Melise, Nov 17, 2005.

  1. Bob Melise

    Bob Melise Stunt Coordinator

    Oct 16, 2004
    Likes Received:
    Hi all i have a denon avr5800 that is hung up in protection mode. when i turn it on it runs through its initial start up cycle then shuts right off.i know what caused this it was an amp that went bad on my powered polk speakers.i unplugged everything that was connected to it and then tried still shuts down. my question is is there a protection reset button on this receiver other than doing a hard reboot for the processor i already tried that. i looked inside for fuses and they all looked fine. my next question is is this something i can have repaired at a local electronics dealer or do i need to take my chances shipping it back to Denon. Does anyone have an idea how much a repair like this cost since it isnt under warranty. any info would be greatly appreciated.please post here or email me at [email protected].

  2. Ed Moxley

    Ed Moxley Cinematographer

    May 25, 2003
    Likes Received:
    Eastern NC
    Real Name:
    MOST of the time, the reason a receiver goes into "Protection Mode", is because there's a frayed speaker wire somewhere, and it touching something it shouldn't. A single strand of wire can cause this.
    Double check all your speaker wires, at the receiver end AND at the speaker end.
    Re-twist the wires and make sure you get a "clean" insertion to the receiver and speaker. If this doesn't work, somewhere in your owner's manual, it should tell you how to reset the receiver to factory settings. Try that. After resetting, you'll need to redo the setup, like the first time you used it.
    Good luck!

Share This Page