What's new

AUDIO BUT NO VIDEO FROM MY PROJECTOR (1 Viewer)

SAY IT LOUD

Auditioning
Joined
Jan 4, 2008
Messages
11
Real Name
TROY
Hi 2 months ago i had my new HTS installed ONKYO TX SR 705 and BEN Q PE 5120 projector, all ok but tonight no picture ? Fired it up like every other time the BEN Q logo will appear on screen, then it will start searching for the picture. For a split second will will get a very distorted image (BLUR) then it will keep searching. The system is set up on s-video and until tonight has worked great. Im thinking a faulty s-video lead? Any help would be fantastic

Cheers
 

Leo Kerr

Screenwriter
Joined
May 10, 1999
Messages
1,698
While it's possible, wires rarely go bad "on their own." Again, however, it is possible. Reseat the connections (pull out both ends and shove 'em back in again.)

Is the video run through your receiver? If so, bypass the receiver and see if that works.

Can you get a working picture from composite? Other S-video devices?

What you need to do is eliminate:
• wires
• source
• any processing/switching boxes (receivers)
• and inputs.

This may be tedious, depending on your system you may have a lot of different combinations to test, but the good news is that the projector appears to be fundamentally okay - that is, it can project, it can form images, and put out a recognizable image (the logo.) Parts of the input cards can go bad; which is probably the worst case scenario for you, but it isn't really likely.

Leo
 

John Dirk

Premium
Ambassador
HW Reviewer
Senior HTF Member
Joined
May 7, 2000
Messages
6,691
Location
ATL
Real Name
JOHN
Since you're using S-Video [BTW - Why???] I would just try connecting another S-Video device directly to the unit. Some PC's have S-Video outs. If not, do you have an older VCR you can use? Anyway, this is the approach I would use. I had a similar problem with my Samsung HD Tuner and it turned out to be the HDMI jack was not making a good connection to its circuit board. When I would press down on it, I could get a good picture, otherwise nothing. Good luck with it.

John
 

SAY IT LOUD

Auditioning
Joined
Jan 4, 2008
Messages
11
Real Name
TROY
Hi Leo the video is from the projector straight into s-video on my samsung HD DVD 1080P player (i dont use vhs i only have a dvd player) then audio from the DVD to the receiver. Cheers Troy from DOWN UNDER
 

Al.Anderson

Senior HTF Member
Joined
Jul 2, 2002
Messages
2,736
Real Name
Al
My guess is that someone (do you have kids?) hit a format switch on the DVD. Check to see if the DVD is now set to 1080i/p; your projector may not pick that up under S-video.
 

SAY IT LOUD

Auditioning
Joined
Jan 4, 2008
Messages
11
Real Name
TROY
I just hooked up my LG DVD/VCR from my bedroom and A PICTURE APPEARED i cant believe it i have a faulty DVD PLAYER. Thanks for the replys everyone. I will be contacting the dealer and samsung tomorrow
 

Ken Seeber

Supporting Actor
Joined
Nov 5, 1999
Messages
787
You should also know that S-video cannot carry the HD signal from your HD DVD player. You need to upgrade your connection to either HDMI or component.
 

Users who are viewing this thread

Latest Articles

Forum statistics

Threads
356,493
Messages
5,114,133
Members
144,102
Latest member
eathree
Recent bookmarks
0
Top