Anyone else have trouble putting the Def Tech logo on your CLR2500?

Discussion in 'Archived Threads 2001-2004' started by Gary.H, Mar 17, 2002.

  1. Gary.H

    Gary.H Stunt Coordinator

    Joined:
    Mar 26, 2001
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    0
    i AM HAVING TROUBLE PUTTING THE LOGO ON THE CENTER CHANNEL. mY VISION IS BAD AND i DON'T WANT TO DO ANYTHING THAT WILL DESTROY THE GRILL/SOCK. aNY SUGGESTIONS OTHER THAN DON'T PUT THE LOGO ON?(already considering that one [​IMG] )
     
  2. Bob_A

    Bob_A Supporting Actor

    Joined:
    Jul 30, 2000
    Messages:
    876
    Likes Received:
    0
    Trophy Points:
    0
    Gary, if you have any concerns, you should probably just leave the logo off. You might want to shoot DT an email: [email protected] Good luck!
     
  3. John H

    John H Second Unit

    Joined:
    Nov 27, 1998
    Messages:
    472
    Likes Received:
    0
    Trophy Points:
    0
    The best method is to locate one of the pins hole first. Press the tip of your index finger "firmly" against the face of the speaker and search for the hole.
    Once you locate the hole press the logos pin in the area and move it around until you feel it fall into alignment. Once you have one pin aligned with one hole the other will line up easily.
    Once the logo is in place hold it firmly against the speakers face and "lightly" tap it in with a hammer covered with a cloth to prevent marring the logos surface.
    John
     
  4. Gary.H

    Gary.H Stunt Coordinator

    Joined:
    Mar 26, 2001
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the help. I appreciate it.
     

Share This Page