What's new

Problems with ARC on 2017 LG OLED (1 Viewer)

Ted Todorov

Senior HTF Member
Joined
Aug 17, 2000
Messages
3,590
I was very happy that the my new LG OLED55C7P has 5.1 output via its ARC, or Audio Return Channel TOSlink output. Sounds great, in perfect sync, etc.

But the last few days it has been cutting off sound altogether for any 5.1 material, be it streaming (HBO, Netflix, etc via AppleTV) or TiVo, or BD player. I was only able to revive it though some random combination of going through the LG's audio menus and playing something from the TV's Amazon Prime app. It has happened three times now - basically it is broken when you turn on the TV, and stays broken until I get lucky enough to "fix it".

Just googling LG OLED ARC produced endless complaints from people with similar experiences... Does anyone have info/hunts? Seems like a bug - any hope LG will bother to fix it?
 

Kevin Collins

Owner, from the first state with COVID-19
Owner
Senior HTF Member
Joined
Jan 14, 2007
Messages
4,486
Location
Seattle, WA
Real Name
Kevin Collins
Hi Ted,

I have the LG OLED65C7P. I use ARC to feed the LG SJ9 5.1.2 Atmos Sound Bar system. I have my system on auto update for FW updates. I have recently noticed some instances where the sound will stop for a couple of milliseconds, even when watching BD from the Oppo. I never noticed that initially when I bought the set, so maybe a FW update is causing it. It makes me wonder if I should turn off the auto FW update on the TV. I'm leaning on doing that.

This is compelling me to send an email to LG to see if they are doing a FW update to solve the problem.
 

Ted Todorov

Senior HTF Member
Joined
Aug 17, 2000
Messages
3,590
Hi Kevin,

Thanks for your info - let me know what LG says/does.

And yes, I have noticed the exact same millisecond sound gaps as well.
 

Users who are viewing this thread

Forum Sponsors

Forum statistics

Threads
348,456
Messages
4,846,035
Members
142,321
Latest member
TurtlePen
Recent bookmarks
0
Top