Progressive

Discussion in 'Playback Devices' started by MartyF, Sep 15, 2003.

  1. MartyF

    MartyF Auditioning

    Joined:
    Aug 31, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I have two questions. First, I just recently purchased the Mitsubishi RPTV WS 48313 and the Sony ProScan DVD NC665p. I have it hooked up using Monster Component, but the picture seems a little blurry. I guess I expected more for my DVDs. I dont' have a lot of first hand experience with this. Is this normal for all 480p, or is it a bad player? Second, I've been trying to research the new Samsung HD931. Would I see a huge difference between my Sony and the Samsung using DVI? It seems that the people that see a considerable difference are using DLP or Plasma monitors. I like the fact that the Sony is a 5 disc changer because I use if for CDs as well, and I'm not sure if I can justify spending an extra $200 dollars for a small difference. Any feedback is greatly appreciated. Thanks.
     
  2. Darryl_B

    Darryl_B Stunt Coordinator

    Joined:
    Mar 2, 2001
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    0
    You might try getting a calibration DVD disc (AVIA or I believe a new cheaper Video Essentials disc was just released) and using it to calibrate your TV set before making any further judgements. Alternatively, you could use one of the later THX optimode features, but you'll get better results using a calibration disc. Afterwards, you may still love your Sony player.

    Enjoy!! - DB[​IMG]
     
  3. Jack Briggs

    Jack Briggs Executive Producer

    Joined:
    Jun 3, 1999
    Messages:
    16,738
    Likes Received:
    129
    Trophy Points:
    0
    Marty, FYI: Please don't post the same question in multple sections. Closed the one in Basics. And from that thread, here was my post:

     
  4. MartyF

    MartyF Auditioning

    Joined:
    Aug 31, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    JB,
    1. I just bought the Mits a week ago, so it shouldn't need to be converged yet, should it? I went through the advanced features on the menu to the convergence option, and everything looked fine.
    2. Yes, Progressive scan is enabled.
    3. I have it hooked up to component 1 input, will the "broadband" say something different on the input?
    4. I bought an optimization disk from BB, maybe I'll try that.
    Thanks
     

Share This Page