loud thump from sub...please help

Discussion in 'Speakers' started by Keiwana, Apr 14, 2005.

  1. Keiwana

    Keiwana Stunt Coordinator

    Joined:
    Jun 20, 2003
    Messages:
    59
    Likes Received:
    0
    I have a problem with my paradigm seismic 12 or my receiver. Last night, I attempted change my surround sound format from dolby digital to dts on pioneer elite 45tx receiver. When I did so, my sub made a very loud thump. Initally, I thought someone was kicking the wall. It was just that loud.

    I turned off my dvd player, but when I changed the surround format, I continued to get the load thump from the sub.

    I checked all of my connections.

    Please help...[​IMG]
     
  2. Keiwana

    Keiwana Stunt Coordinator

    Joined:
    Jun 20, 2003
    Messages:
    59
    Likes Received:
    0
    Does anyone have any ideas?
     
  3. Aaron_Mum

    Aaron_Mum Stunt Coordinator

    Joined:
    Jun 29, 2003
    Messages:
    133
    Likes Received:
    0
    I'll bet its your reciever. It is probably sending a wierd signal to the sub when you change formats. If it were me I'd get it checked out first. Sorry I can't offer anything more than a guess.
     
  4. Vincent_S

    Vincent_S Second Unit

    Joined:
    Nov 29, 2002
    Messages:
    450
    Likes Received:
    0
    What about unplugging and plugging the receiver back in? Maybe resetting? Sorry, that's all I can come up with. Probably not much help.
     
  5. Keiwana

    Keiwana Stunt Coordinator

    Joined:
    Jun 20, 2003
    Messages:
    59
    Likes Received:
    0
    I tried to re-set it, and I did the auto calibration twice;

    Problem still there
     
  6. Thomas_A

    Thomas_A Second Unit

    Joined:
    Feb 2, 2001
    Messages:
    398
    Likes Received:
    0
    sounds too me as if there is a bad ground or a ground loop somewhere in the set up. My sub thumps...but only when I turn off the reciever (ever since my house got zapped and sub repaired)..wich is the caps just doing a final quick discharge.

    do you have any other system or friends system to try the sub with? if you do..that might isolate wich is causing wich.

    good luck
     
  7. Keiwana

    Keiwana Stunt Coordinator

    Joined:
    Jun 20, 2003
    Messages:
    59
    Likes Received:
    0
    Thomas,

    I have had the sub for about 2 months. Nothing has changed in my sub since that time. The problem started this week.
     
  8. Clinton McClure

    Clinton McClure Casual Enthusiast
    Supporter

    Joined:
    Jun 28, 1999
    Messages:
    4,227
    Likes Received:
    330
    Location:
    Central Arkansas
    Real Name:
    Clint
    Sounds like changing formats might be telling the sub amp to turn off then back on quickly?

    Thomas - I've heard of ground loops causing this, but wouldn't you hear a buzz or hum if there is one?

    Have you tried plugging the amp into a different receptacle?

    I don't know what kind of connections you can run between your receiver and sub, but if you can switch from RCA to XLR cable, you might try that.

    I get a loud thump if I turn off my BFD before my sub amp shuts down. It takes about 10 minutes for my sub amp to shut down (Paradigm PDR-10) so I'm always forgetting to shut off the BFD.

    Keiwana - A little aside from the subject, how do you like the Siesmic 12?
     
  9. Keiwana

    Keiwana Stunt Coordinator

    Joined:
    Jun 20, 2003
    Messages:
    59
    Likes Received:
    0
    Clinton,

    The sub is great. It blends well with my athena bookshelves... very musical. It also has the power to shake my 28 by 17 ft room. I'm not even running it half of its potential.

    I am from Fort Smith Ar. Where is Plummerville?
     
  10. MikeNg

    MikeNg Second Unit

    Joined:
    Jan 22, 2004
    Messages:
    440
    Likes Received:
    0
    What if you go from DD to no surround setting (direct/stereo)? Any pop? When the popping occurss, does the power indicator on the sub amp (if there is one) remain on constantly?

    Do you have another sub or a tape deck? Try plugging it in to the sub-out, and see if a) the second sub does the pop or b) a signal registers on the tape deck.
    This will at least tell you whether it's the sub or a signal hitting the sub.

    Really strange thing. I've never heard of this before.
     
  11. Clinton McClure

    Clinton McClure Casual Enthusiast
    Supporter

    Joined:
    Jun 28, 1999
    Messages:
    4,227
    Likes Received:
    330
    Location:
    Central Arkansas
    Real Name:
    Clint
    Keiwana - Plumerville is about 2 hours south of Fort Smith...about 45 minutes NW of Little Rock.

    I almost bought a Servo-15 last fall but it's a little too much sub for my HT room. My local Audio Express manager told me he would be getting a Seismic 10 and/or 12 for his Paradigm Reference showroom, but I haven't gone in a few months to see if he did.
     
  12. Keiwana

    Keiwana Stunt Coordinator

    Joined:
    Jun 20, 2003
    Messages:
    59
    Likes Received:
    0
    Clinton,

    Is you Audio express in Conway or Russellville? I have been to one in Russellville? They did not have any of the studio speakers on display?

    I shop at Stereone of Fort Smith. I am able to get a descent discount.
     
  13. Clinton McClure

    Clinton McClure Casual Enthusiast
    Supporter

    Joined:
    Jun 28, 1999
    Messages:
    4,227
    Likes Received:
    330
    Location:
    Central Arkansas
    Real Name:
    Clint
    I go to the one in Conway since it's about 10 minutes from my house. I've known the manager there for over 10 years and I get treated well.
     
  14. MikeNg

    MikeNg Second Unit

    Joined:
    Jan 22, 2004
    Messages:
    440
    Likes Received:
    0
    Hey Keiwana, did you ever get this to work? What was the problem?
     

Share This Page