What's new

Problems with Pure Acoustics RB1150 subwoofer.. (1 Viewer)

JCRF1

Auditioning
Joined
Dec 25, 2008
Messages
1
Real Name
Justin
Hey folks, I'm hoping some of you can help me with an issue that has recently started to effect my subwoofer. I've searched on google for some info but my results came up short..

I bought a Pure Acoustics RB1150 powered subwoofer (175W) to be used for my home theatre system, mostly for video gaming and movies. It worked alright, but nowadays whenever I switch on the sub it will just start rumbling and getting alot of weird feedback and then just stops dead! The green light is still on on the back and it's still receiving power, but it still dies out. Sometimes it wont die out and will work for a couple minutes of use but it ALWAYS eventually just stops working.

My amp that I'm using has a single-jack subwoofer pre-out which connects to the 2 in jacks on the back of the sub. The cable appears fine and like I said it worked for a while. The subwoofer has only seen casual use for a few months and received no damage...

Any ideas guys? Any tips will be appreciated. I paid $150 for this sucka...
Thanks and merry x-mas.

-Justin F
 

Robert_J

Senior HTF Member
Joined
Aug 22, 2000
Messages
8,350
Location
Mississippi
Real Name
Robert
Check with the Pure Acoustics customer service but for a $150 sub, I wouldn't expect much. It sounds like your sub amp is dieing. If you are handy with tools and don't mind a small project, there are dozens of amps that can be used to replace yours. Most will cost as much as your sub did though but they will be much higher quality.

-Robert
 

Users who are viewing this thread

Sign up for our newsletter

and receive essential news, curated deals, and much more







You will only receive emails from us. We will never sell or distribute your email address to third party companies at any time.

Latest Articles

Forum statistics

Threads
357,016
Messages
5,128,528
Members
144,245
Latest member
thinksinc
Recent bookmarks
0
Top