Problem when connecting w/ component cable

Discussion in 'Archived Threads 2001-2004' started by StevenS, Feb 12, 2002.

  1. StevenS

    StevenS Auditioning

    Joined:
    Jan 4, 2002
    Messages:
    7
    Likes Received:
    0
    Hi everyone!

    I have Sony PFM500A2 plasma TV. Recently I bought progressive scan JVC XA-S90 DVD player. I used it for a month using regular composite cable connection. Finally, I decided to try progressive scan video and connected DVD to my TV thru component cable that came in with DVD.

    My TV has a BNC input, so I used RCA-to-BNC adapters for connection.

    What was strange is that after connecting with component cable, picture became much worse that with composite.

    I had a lot of artifacts(small cubes)and bad black level picture. I must admit that TV itself has bad black level, but with component it became more visible.

    What is wrong?

    Thank you in advance.
     
  2. Phil A

    Phil A Producer
    Supporter

    Joined:
    Oct 1, 2000
    Messages:
    3,145
    Likes Received:
    30
    Location:
    Central FL
    Real Name:
    Phil
    By any chance is it a TV bought at Costco? I spoke to one of the people I know in the business about a month ago and he believed that the ones that Costco was selling and possibly others were designed for industrial use and he heard the component inputs do not work or work properly. Have no idea as to the factual nature of info, just passing along what I have heard.
     

Share This Page