What's new

ICBM buzzing sound- anybody else experience this? (1 Viewer)

Conroy Tesa

Stunt Coordinator
Joined
Jun 26, 2001
Messages
167
I just noticed this this morning.
I installed this on the weekend but never noticed it till now. There is a low buzzing coming from all speakers that doesn't change with volume.
It is connected between my pre and amps as a global bass management.
I have it plugged into the same power bar as my amps.
Could this be the problem?

Any other suggestions
 

Philip Hamm

Senior HTF Member
Joined
Jan 23, 1999
Messages
6,874
Is the ICBM right on top of the amps? Are the cables well shielded? I've noticed the same thing and wondered as well.
 

Philip Hamm

Senior HTF Member
Joined
Jan 23, 1999
Messages
6,874
Wow, I would think that the ICBM should be better shielded than that. With my cable management it would be a huge pain in the ass to reconfigure so that the ICBM is on top of my prepro. I may move it anyway.... :frowning:
 

ling_w

Second Unit
Joined
Sep 3, 2001
Messages
426
These low budget equipment don't seem to use differential, complementry or balanced topology or shield plane on the PCB. I guess whatever it takes to get the job done, and with the relative complexity of the product, a good enough design would do, especially when it comes to the HP/LP filtering.
 

Conroy Tesa

Stunt Coordinator
Joined
Jun 26, 2001
Messages
167
I did move it one shelf up from the top of my 3 channel amp for the center and rears to on top of my pre pros.
The buzz is now completely gone.
Do the move, or all you will here is that buzz. For me that is all I was listening for.
 

Users who are viewing this thread

Forum Sponsors

Forum statistics

Threads
348,477
Messages
4,847,155
Members
142,331
Latest member
Doug2000
Recent bookmarks
0
Top