Bettercables SilverSerpent component cables Dead?!?

Discussion in 'Accessories, Cables, and Remotes' started by Mathew Shelby, Jun 3, 2003.

  1. Mathew Shelby

    Mathew Shelby Second Unit

    Joined:
    Dec 5, 2002
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    0
    The title pretty much says it all. I have had the cables around 9 months and tonight I went to turn on the projector (Infocus X1 via VESA adaptor) and there was no video of any sort. I love these cables and I really want to get to the bottom of this. I have left a message for [email protected] and I am waiting to hear from him. I will keep everyone posted. BTW, before anyone asks, I have checked both ends of the cable and everything is still intact. Anyone have any idea what might be going on?
     
  2. LarrySkelly

    LarrySkelly Stunt Coordinator

    Joined:
    Jan 9, 2001
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Is the bulb gone? Hard to imagine that the cable has failed...
     
  3. Mathew Shelby

    Mathew Shelby Second Unit

    Joined:
    Dec 5, 2002
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    0
    Are you referring to the bulb on the projector? No, its not gone-less than 100 hours on it and it works for all other sorts of material. It even works w/ another set of component cables.
     
  4. Chu Gai

    Chu Gai Lead Actor

    Joined:
    Jun 29, 2001
    Messages:
    7,270
    Likes Received:
    1
    Trophy Points:
    0
    Well that's disturbing isn't it! I'm sure if the cables were defective, BC will make good promptly.
     
  5. Mathew Shelby

    Mathew Shelby Second Unit

    Joined:
    Dec 5, 2002
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    0
    Just wanted to update everyone. They emailed me this afternoon and I will be returning them so they can look at them.
     
  6. Bob McElfresh

    Bob McElfresh Producer

    Joined:
    May 22, 1999
    Messages:
    5,182
    Likes Received:
    0
    Trophy Points:
    0
    It's a little strange..

    Only one of the cables carry the video signal, the other two carry the color-difference signals. If the "Y" cable died, you would not get any video. But as a test you could use one of the other wires in place of the "Y" wire (the cables are all identical except for colored markings).

    If there is a failure, the most likely spot is the coax-to-connector interface. This is usually a crimped, mechanical connection that can pull loose depending upon the amount of strain.

    But I am sure they will take care of you.
     
  7. Thomas Nichols

    Thomas Nichols Stunt Coordinator

    Joined:
    Nov 27, 1999
    Messages:
    115
    Likes Received:
    0
    Trophy Points:
    0
    Let us know what happens. I am interested to hear what they say.
     
  8. Parker Clack

    Parker Clack Schizophrenic Man
    Moderator

    Joined:
    Jun 30, 1997
    Messages:
    12,216
    Likes Received:
    59
    Trophy Points:
    9,110
    Location:
    Kansas City, MO
    Real Name:
    Parker
    Mathew:

    Did you try anything else through the 15 pin input on the projector like from the output of your PC to see if that works?

    Parker
     
  9. Mathew Shelby

    Mathew Shelby Second Unit

    Joined:
    Dec 5, 2002
    Messages:
    344
    Likes Received:
    0
    Trophy Points:
    0
    Parker,
    No I haven't as of yet. I was beginning to wonder if it could have been the VESA adaptor, I will check this out when I get home.
     

Share This Page