1. Guest,
    If you need help getting to know Xenforo, please see our guide here. If you have feedback or questions, please post those here.
    Dismiss Notice

Sanyo PLV-Z5 lamp problem

Discussion in 'Displays' started by BobR, Sep 1, 2007.

  1. BobR

    BobR Active Member

    Joined:
    Jun 30, 1997
    Messages:
    26
    Likes Received:
    0
    I have a PLZ-5 about 6 mo. old and the other day it would not power up and "replace lamp" was flashing. I thought that was a pretty short time for a lamp to last (I previously had a Z2 for 3 years and never replaced the lamp) but I went ahead and ordered the lamp. I got the new one and put it in and have the same symptom.

    Does anyone have any similar experiences with this projector and if so do you think I got a new defective lamp or the projector has something else wrong with it?

    Anyone know of some sort of master hardware reset I could try? Anything like that?

    Thanks,

    Bob
     
  2. Dave1

    Dave1 Member

    Joined:
    Dec 20, 2006
    Messages:
    14
    Likes Received:
    0
    Bob, I am interested to find out if you found what the problem is with your machine. I am considering picking up this sanyo model for myself.
    Dave
     
  3. John Dirk

    John Dirk Well-Known Member

    Joined:
    May 7, 2000
    Messages:
    414
    Likes Received:
    0
    Mine's about the same age and no such problems. How many hours [of use] did the projector say the lamp had? Also, is the fan OK? Other than that, give Sanyo a shout. 3 year warranty you know.
    Gunny
     
  4. BobR

    BobR Active Member

    Joined:
    Jun 30, 1997
    Messages:
    26
    Likes Received:
    0
    I hadn't checked the hours. We use it a lot but we used the Z2 just as much. I didn't notice any fan problem but now I can't check anything because it won't power up. That's why I was hoping there might be some kind of hardware reset so if the bulb isn't really bad I could get it powered up long enough to see what the problem might be. If it's not the bulb of course it will go back to Sanyo anyway but I thought I might have just gotten a bad new bulb and I'd hate to send it back and have them tell me the bulb was dead.
     
  5. John Dirk

    John Dirk Well-Known Member

    Joined:
    May 7, 2000
    Messages:
    414
    Likes Received:
    0
    I see your point. Well, mine shows a lamp usage of 752 hours and I average about 10 hours a week. Sanyo doesn't say how many hours we should expect, but 2000 is what I've heard as average. If you use yours significantly more than I do, I guess its concievable that the bulb is fried. But a bad replacement bulb too? That's kind of hard to believe. I would try contacting Sanyo to see if they have any repair facilities in your area.

    Good luck [I feel your pain]

    Gunny
     
  6. radfordian1

    radfordian1 New Member

    Joined:
    Oct 22, 2008
    Messages:
    1
    Likes Received:
    0
    Hi Bob
    Yes
    Inside the case is a thermal reset button. Simply pull off the cover and push it. This is not something Sanyo will tell you, they want you to send it in for a "repair", even if still under warranty. They don't want us messing inside the case. Are you at high altitude? If so you may need to select a high altitude fan setting in menu. This speeds up the fan. Or just make sure it has lots of air to breath. Good luck.
    Bob R (too)[​IMG]
     
  7. yusmereza

    yusmereza New Member

    Joined:
    Aug 7, 2009
    Messages:
    2
    Likes Received:
    0
    hi
    im having same problem, did you fix it?
    im not sure how to open the top without breaking something
    removed 3 screws at the bac but still no jow
    ive even replaced the lamp.costed 400 dollars!
    help
     
  8. yusmereza

    yusmereza New Member

    Joined:
    Aug 7, 2009
    Messages:
    2
    Likes Received:
    0
    hi guys,

    i hope i can get some help. ive had the same problem with my z5. after a few months using it, the replace lamp light came on and i thought it was the lamp gone (although i thought it was very quick) and went to spend another hundreds purchasing another lamp.
    after replacing it, i cant even get the thing to turn on, everytime i switch it on, it just shuts the front cover and the dreaded 'replace lamp' button comes on again. i tried opening the case as adviced but could not get it open.is there more than the 3 rear screw i need to unscrew before i can open the cover?

    please guys, i need help before i throw the thing in the bin!
     
  9. Chiapet

    Chiapet New Member

    Joined:
    Sep 22, 2009
    Messages:
    1
    Likes Received:
    0
    My two cents:

    Starting around 400hrs my Z5 started doing the same thing. I cleaned/replaced the filters, made sure the high alt fan was selected and tried again. I found that on my unit, if you do a hard reset (turn off the power then physically remove the power cord - count to three and start it back up) the unit will come on normally. Sometimes I have to do it twice. I have never pushed the thermal reset button.

    Its a lazy man's band aid, but I've only had to do it every month or two and have now nursed it along to 958 hours. Obviously YMMV...
     
  10. mazott

    mazott Member

    Joined:
    Jan 1, 2010
    Messages:
    7
    Likes Received:
    0
    Just today, after 875 hours and three years of good work, the plv-z5 started shutting down with the yellow led blinking. After pressing what I thought a thermal reset switch inside, the projector was then back to operate!
    Just worth mentioning that the switch was rather hard to press and it in fact snapped inward within its case.
    Thank you
     
  11. luisjan

    luisjan New Member

    Joined:
    Jan 6, 2010
    Messages:
    1
    Likes Received:
    0
    Hi Marco or Bob Radford, could you just paste a photo, which "thermal reset button" you have pressed? Thanks
     
  12. mazott

    mazott Member

    Joined:
    Jan 1, 2010
    Messages:
    7
    Likes Received:
    0
    Hi,

    let me go inside under the hood once again in the week-end and I'll be back with the photo, cheers, Marco
     
  13. TonyArmstrong

    TonyArmstrong New Member

    Joined:
    Jan 9, 2010
    Messages:
    4
    Likes Received:
    0
    Hi there!
    I'm an AV tech and I've just noticed your problem here. Simply locate the tgree screws on the base of the projector and the three screws on the back. They all have little arrows pointing at them! Then with the projector the right way up, carefully lift the top shell directly up. Note, there is a cable run attatched but you do not need to remove it for this operation. Looking inside the projector you will clearly see a thermal reset switch to the right rear of the machine, a sort of black/white push button. Carefully push it and then pop the top back on. before you put the screws back in, plug the power cord back in and test if it works. Remember to reset the lamp timer in the menu!!

    I have one of these excellent projectors on my workbench at the moment and I'll post a few pics if you really want them, OK.
     
  14. TonyArmstrong

    TonyArmstrong New Member

    Joined:
    Jan 9, 2010
    Messages:
    4
    Likes Received:
    0
    Here's the pic for the Sanyo reset, sorry about the arrow, I'm a technician, not a graphic artist!!
    It's the button with the white top as indicated by my photo.
    What you can't see in this pic are the empty pizza boxes and Pepsi cans, neither of which are essential for this operation!
    Remember, only remove the 6 screws that have arrows pointing at them and always remove the power cord first!!
    [​IMG]
     
  15. mazott

    mazott Member

    Joined:
    Jan 1, 2010
    Messages:
    7
    Likes Received:
    0
    Hello,

    sorry for the late response but I've been meamwhile hit by Collateral ;-)


    Here attached my contribution. You can see the switch slightly enlarged. The tiny white button must be pressed gently but firmly, mine has been pressed until it somehow snapped inward.

    [​IMG]


    @TonyArmostrong:
    I didn't reset my lamp conter, why should that be done? Thanks.
     
  16. TonyArmstrong

    TonyArmstrong New Member

    Joined:
    Jan 9, 2010
    Messages:
    4
    Likes Received:
    0
    Hi!
    You should always reset your lamp counter for a couple of good reasons.
    Some advanced projectors such as Panasonic will actually shut themselves off after exceeding the recommended lamp hour units as a precaution. Trust me, if a lamp explodes due to excessive hours it can take colour wheels, heat screens and even lens optics with it!
    A projector has no way of knowing the condition of the lamp except by the built in timer function on the chassis.
    Which is why you should always reset the timer.
    This function isn't always in plain view in the menu, it's often buried in some sub menu somewhere.
    Just check your instruction book.
    I always print out a quick guide and affix it to the back of the unit to remind customers how to do it!!
     
  17. mazott

    mazott Member

    Joined:
    Jan 1, 2010
    Messages:
    7
    Likes Received:
    0
    Thank you for your reply. However my thoughts were rather different, that is to keep the counter going ahead where it left where the thermal switch independently shut down - i.e. because of the temperature and not of the lamp life span being exceeded - in order to faithfully let it follow the lamp life progression.
    Thanks, Marco
     
  18. TonyArmstrong

    TonyArmstrong New Member

    Joined:
    Jan 9, 2010
    Messages:
    4
    Likes Received:
    0
    I agree, perhaps I misunderstood!
    What I meant was that one should reset the timer when replacing the lamp with a new one.
    If you are using the same lamp, there is no reason to reset!
     
  19. pkhits

    pkhits New Member

    Joined:
    Sep 27, 2010
    Messages:
    1
    Likes Received:
    0
    Thanks a lot, guys! Pressing that key really solving this problem!
     
  20. inneedofhelp

    inneedofhelp New Member

    Joined:
    Jan 6, 2011
    Messages:
    1
    Likes Received:
    0
    Tony, just ready your post. I have this same projector it has about 800 hours on this bulb and I have had to reset this about 3 times. Today I got the same issue as described above. I opened the case to press the reset button again and it wasn't triggered it was really lose. So I tried to turn it on again and it wouldn't turn on still. So I tried to turn it on again and I saw blue sparks and sparking sounds coming from just left of that thermal switch. I thought it was the flex capacitor. Any ideas what the issue is?

    Todd
     

Share This Page