Onkyo HT-S650 and clicks?

Discussion in 'Archived Threads 2001-2004' started by David Dhaus, Jun 24, 2002.

  1. David Dhaus

    David Dhaus Agent

    Joined:
    Jun 16, 2002
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    0
    Since I am going to audition the Kenwood 505 and Onkyo 650 HTIB due to my minuscule budget [​IMG], I've been reading up on them. Another forum has numerous complaints, or many complaints from just a few persons, about the Onkyo receivers "clicking" and/or blowing their speakers. Is this a problem with the 650? It sounds as if the complainers' old speakers don't match the new receiver, even though the specs indicate they should have been fine. My guess (and hope) is that the HTIB is matched pretty well and that this should not be a problem. So, for you 650 owners, what is the story?
     
  2. Shana

    Shana Stunt Coordinator

    Joined:
    Jun 16, 2002
    Messages:
    207
    Likes Received:
    0
    Trophy Points:
    0
    I'm sorry noone has responded to you yet. [​IMG]
    If I had some wisdom to share I would.
    Best of luck,
    Shana
     
  3. Christopher R

    Joined:
    May 17, 2002
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    David: My 650 has worked flawlessly with the included speakers---no clicks or anything like that. I have not tried it yet with other speakers. I also don't play it at ear-piercing volumes.

    Hope this helps,

    Chris
     
  4. Chet_F

    Chet_F Supporting Actor

    Joined:
    Mar 1, 2002
    Messages:
    776
    Likes Received:
    0
    Trophy Points:
    0
    I can't speak from experience on the 650 but my 494 works flawlessly and I cannot be any happier.

    Good Luck,

    Chet
     
  5. Aaron Gould

    Aaron Gould Stunt Coordinator

    Joined:
    Mar 4, 2002
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    London, Ontario, Canada
    Real Name:
    Aaron Gould
    David,

    I have an Onkyo DS656 receiver and experienced an occasional clicking from my speakers. My front speakers are Mirage OM-10, along with a Mirage OM-R2 center channel.

    My rear speakers were a pair of Sound Dynamics (don't know the model, but they were a relatively low end set) that were not a high wattage.

    I have since upgraded the rears to a timbre-matched Mirage OM-R2 pair. Ever since upgrading the rears, the clicking has gone away.

    My suspicion is that the older Sound Dynamics were incapable of handling the power from the high-current DS656.

    I'm not sure this helps you at all, but that's my experience with a clicking Onkyo!
     
  6. Michael Malonzo

    Michael Malonzo Auditioning

    Joined:
    Jul 12, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I have had the Onkyo HT-S650 for about a month now and have no problems. I think this system is a steal at around $500.
     

Share This Page