Dead Ringers - has anyone else had the no-sound problem?

Discussion in 'Archived Threads 2001-2004' started by Joe Rivera, Dec 27, 2002.

  1. Joe Rivera

    Joe Rivera Auditioning

    Dec 26, 2000
    Likes Received:
    I rented Dead Ringers tonight - the non-Criterion version (haven't seen Criterion around for rental). When I got it home and plugged it into my DVD I got a perfect picture with absolutely no sound. At first I thought cables had been pulled out, the receiver was on the wrong setting, blah blah blah. But after spending half of an hour trying every setting I could think of (and trying other DVDs - which worked perfectly). I gave up and returned it to the video store for a different film.

    Of course when said store plugged it into their machine, it worked perfectly.

    Has anyone else experienced this problem with that particular DVD - or does anyone know of a glitch in old DVDs that causes this to happen?

    I am particularly spooked ( in a joking way) about this DVD not working - about 4 years I rented another Cronenburg film - "Crash" on VHS and it too wouldn't play in my particular brand of VCR. It's as if the fates are blocking me from seeing Cronenburg's films.

    For the record, my DVD player is a Sony DVP-S560D.

    Joe Rivera
  2. Robert_eb

    Robert_eb Supporting Actor

    Sep 14, 2001
    Likes Received:
    I had the same problem with this title. I just took it back and bought the Criterion version which I should have purchased from the start.

Share This Page