Cyberhome CH-300 playback anomaly

Discussion in 'Playback Devices' started by Blaine Skerry, Jan 7, 2004.

  1. Blaine Skerry

    Blaine Skerry Second Unit

    Joined:
    Aug 15, 2001
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    0
    I picked up a Cyberhome CH-300 last night and immediately tried several of my DVD's. The only peculiarity I have noticed is that the player refuses to play both THE ABOMINABLE DR. PHIBES and DR. PHIBES RISES AGAIN. The MGM logo comes on screen, and just before the DVD menu comes up, the player shuts itself off. I tried other MGM discs with no problems. If anyone who has the Cyberhome unit and either of the two above-mentiond DVD's would try them and report here, I would be grateful. Thanks.

    I tried the player at the Region 1 and the Region 0 setings with the same results.
     
  2. Jesse Skeen

    Jesse Skeen Producer

    Joined:
    Apr 24, 1999
    Messages:
    4,493
    Likes Received:
    339
    Trophy Points:
    4,110
    I don't have a Cyberhome, but I work for a retailer and remember a customer sending back those two titles because they would not play on their machine.
     
  3. Blaine Skerry

    Blaine Skerry Second Unit

    Joined:
    Aug 15, 2001
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the reply. I thought it might be something like that. They will play on my old Panasonic A-120. Is there a web site that lists problem DVD's and DVD players?
     

Share This Page