1. Guest,
    If you need help getting to know Xenforo, please see our guide here. If you have feedback or questions, please post those here.
    Dismiss Notice

speaker compatability?

Discussion in 'Speakers' started by Scott Turtle, Sep 28, 2011.

  1. Scott Turtle

    Scott Turtle Member

    Joined:
    Nov 27, 2004
    Messages:
    7
    Likes Received:
    0
    I have a Denon AVR 1911 which runs at 95 watts per channel and am using a Klipsch Quintet III box set of speakers for my mains and surrounds. When I moved to 7.1 I got some hifi works in-ceiling mount speakers (from Costco). They're rated at 65W. My problem is the amp keeps shutting down in safety mode when I turn the volume up. I've done some trouble shooting at it only happens when I have these hifi speakers activated. Interestingly, it also cuts out when the speakers are activated but the wires are unhooked from the wall. I'm not sure what's up with that last part, but I'm wondering - did I go too cheap on the speakers, or could something else be going on? :huh: Thanks for any help.
     
  2. Al.Anderson

    Al.Anderson Well-Known Member

    Joined:
    Jul 2, 2002
    Messages:
    2,464
    Likes Received:
    56
    Real Name:
    Al
    Given your statement , "Interestingly, it also cuts out when the speakers are activated but the wires are unhooked from the wall.", the only thing that makes any sense is that you have a wire strand or two touching another terminal on the back of the receiver. Assuming the speakers a 6 ohms or higher, the speakers shouldn't be causing any problem. And speakers would have nothing to do with it when they aren't connected. I suppose you could have a short in the wires somewhere in the run. You could attach a meter across the +/- wires on the speaker end (with the speakers not connected) and if you get any resistance reading you have a short. Of course, it could also be a defective amp, but the odds are on a crossed wire near the amp.
     
  3. Scott Turtle

    Scott Turtle Member

    Joined:
    Nov 27, 2004
    Messages:
    7
    Likes Received:
    0
    Thanks! I checked the connections behind the amp, at the wall, behind the wall, and at the speaker and didn't find much- No wires touching each other, and I wrapped up one that was stripped too far. But the wrapping didn't change anything. I can look to see if the wires are touching or are really close to another post creating the short. I'll also try the meter at the speaker end to see what's up there. If I take the wires off the amp, but leave the speakers activated, that shouldn't cause a short, right? Right now I took the wires off the wall. I can take the wires out of the amp and test it. If I still get the short, would that mean a bad amp?
     
  4. Robert_J

    Robert_J Well-Known Member

    Joined:
    Aug 22, 2000
    Messages:
    8,264
    Likes Received:
    46
    Location:
    Mississippi
    Real Name:
    Robert
    It means something isn't right with the amp. How did you check your connections? Multi-meter to check resistance?
     
  5. Scott Turtle

    Scott Turtle Member

    Joined:
    Nov 27, 2004
    Messages:
    7
    Likes Received:
    0
    So far I've just done a visual check to make sure no wires were touching in the wrong way and that I had the positive to positive etc... I actually don't have a meter. I was going to go to Radio Shack to pick one up. Is there a specific one I get of if i ask for a 'multi-meter' would that be fine?
     
  6. Al.Anderson

    Al.Anderson Well-Known Member

    Joined:
    Jul 2, 2002
    Messages:
    2,464
    Likes Received:
    56
    Real Name:
    Al
    Multi-meters aren't expensive, but if you don't have one, you could just run another set of wires to the speakers outside of the wall. If this run works fine, then there's something wrong with the wires in the wall/ceiling. Just for good measure, if the receiver provides bannana plug connections you might want to use some to connect to your stereo; just to make sure there are no loose wire strands.
     
  7. Robert_J

    Robert_J Well-Known Member

    Joined:
    Aug 22, 2000
    Messages:
    8,264
    Likes Received:
    46
    Location:
    Mississippi
    Real Name:
    Robert
    I've used the old version of this one for about 20 years - http://www.radioshack.com/product/index.jsp?productId=4214667
     
  8. Scott Turtle

    Scott Turtle Member

    Joined:
    Nov 27, 2004
    Messages:
    7
    Likes Received:
    0
    Thanks for the tip. As I've done all my testing I've cleaned up the wires and insulated ones that looked like I stripped too far. First I wired up both speakers using wires outside the wall. They worked fine. Then I hooked up the left speaker using the wall wire and tested again - no problem. I then hooked up the right speaker and it cut out. So my conclusion is it's in the wire for the right speaker. I'm a little confused now - the only connection left is the one in the wall. I ran a single line from the wall outlet, up the wall, through the ceiling and to the speaker. So the only 2 possibilities are the hook up behind the wall or a nail in the wire somewhere in the run? I didn't have time yet to take apart the hookups in the wall to see if I've got something wrong there. I'll get to that over the weekend. Thanks for all the tips guys; it's helped a bunch. Let me know of any other ideas.
     
  9. Scott Turtle

    Scott Turtle Member

    Joined:
    Nov 27, 2004
    Messages:
    7
    Likes Received:
    0
    Thanks. If the testing suggested by Al.Anderson doesn't work, I'll look into that.
     
  10. Scott Turtle

    Scott Turtle Member

    Joined:
    Nov 27, 2004
    Messages:
    7
    Likes Received:
    0
    Boy have I learned a valuable lesson. I thought I was careful attaching the wires, but I've learned that too much lead can cause an arc. I looked behind the wall and found the positive wire of the left was passing completely through the coupler and nearly touching the positive pole for the right speaker. I insulated the tip leaving only a small portion available to attach to the pole, so it couldn't pass all the way through. Result: no cut out! Now I can listen to Black Hawk Down without cut out, and my daughter can listen to the opening scene of cars without interruption. :D Thanks for the help in trouble shooting!
     

Share This Page