I get white specs using progressive output on myRCA RP6001P into a Mits 55907

Discussion in 'Archived Threads 2001-2004' started by Kent W, Jul 29, 2002.

  1. Kent W

    Kent W Auditioning

    Joined:
    Jan 7, 2001
    Messages:
    4
    Likes Received:
    0
    [​IMG] I bought two of these units and both do the same thing. If i use the basic component output 480i signal then the picture is ok but when I try to use the 480p output, the general picture has the clarity of HD but these little white specks that flicker in the red to lighter areas of the picture.
    Is this the fact that I bought a piece of crap, The guy at the Big Screen Store thinks so...
     
  2. Eric T

    Eric T Second Unit

    Joined:
    Apr 1, 2001
    Messages:
    266
    Likes Received:
    0
    I have a WS-55807 and have had no problems whatsoever, after about 16 months of use. Just based on my experience, I would say that the TV is not at fault. If it were me, and I was having a problem, I would point to the inexpensive RCA equipment before the expensive Mitsubishi equipment.

    Try another DVD player and see how you do. FYI, I use a JVC D723, and the picture is great. You can get them for about $200-$250 now.
     
  3. Kent W

    Kent W Auditioning

    Joined:
    Jan 7, 2001
    Messages:
    4
    Likes Received:
    0
    It is definitely the DVD player. I took it to the Store and we saw the same problem on their tv.

    RCA SHOULD HAVE TO FIX THIS, and since we are a dealer for them, I am going to raise hell with them!

    Thanks for the suggestion on the DVD player, I also heard Toshiba is great.
     

Share This Page