Jump to content



Photo
- - - - -

Onkyo NR905 3d Problem


  • You cannot start a new topic
  • Please log in to reply
2 replies to this topic

#1 of 3 John-Miles

John-Miles

    Advanced Member

  • PipPipPip
  • 1,201 posts
  • Join Date: Nov 29 2001

Posted November 11 2013 - 02:28 PM

Ok so im praying someone here can help me, ive got an Onkyo NR905B and i use my PS3 as my blu-ray player.

 

Currently im set up as follows

 

PS3 Output via HDMI to HDMI splitter

 

HDMI splitter to LG 3D tv

and HDMI splitter to Onkyo NR905B

 

when watching non 3d content this works fine, i get video and i get HD audio through the onkyo

 

However when i watch 3d content i get the video but no signal att he Onkyo.

 

Now i put in the splitter hoping to avoid this thinking that while the onkyo wont pass through a 3d signal it would at least process the audio from the HDMi cable, but it seems it wont even do that when there is a 3d signal in the cable.

 

Is there anyway to get my Onkyo to only take the audio signal from the HDMI cable? when my PS3 is going thats all i really need it to do.


Cheers

John

#2 of 3 schan1269

schan1269

    HTF Expert

  • 11,952 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted November 11 2013 - 02:48 PM

Are you sure you get lossless audio with a splitter? That has never worked on every other system I've ever seen(and it isn't supposed to).

 

And if your 905 won't pass a 3D signal(have you tried? I've been successful on a few top tier 1.3 AVR)...you will nead a dedicated twin HDMI BD player.



#3 of 3 John-Miles

John-Miles

    Advanced Member

  • PipPipPip
  • 1,201 posts
  • Join Date: Nov 29 2001

Posted November 11 2013 - 03:13 PM

Hi Sam,

 

Ive tried before ans unfortunately its true the 905 wont pass through the 3d signal :(

 

I just popped int he avengers as a test and witht he 2d BD disc i get the lossless sound and video through the splitter.

Now to be fair it shows as multichannel on my amp as the PS3 does the lossless decoding internally and just outputs the sound.

 

Then i popped in the 3d disc and i get picture but the amp says no sound now.

 

I am pretty sure i can solve the problem if i can tell the amp somehow that its only an audio signal, i think it detects the 3d signal and just freaks out and does nothing since it cant pass it through.

 

if this does not work then i will just go with an optical output when im watching 3d but thats a major pain.


Cheers

John




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users