What Did I Do Wrong With These Passive Radiators?

Discussion in 'Home Theater Projects' started by Greg Conti, Feb 22, 2005.

  1. Greg Conti

    Greg Conti Stunt Coordinator

    Joined:
    Mar 6, 2000
    Messages:
    71
    Likes Received:
    0
    OK...I seriously screwed something up here. I built a 120L sub with a Dayton Titanic mkIII with two Adire Audio 15" passive radiators loaded with an additional 1015 grams (1300 grams total) each. Based on Unibox and WinISD Pro, I should not have come close to the excursion limits of the PRs. This is kind of a drag as I have now destroyed $200 worth of passive radiators, about $50 worth mass supplies, and alot of time and effort. So much for my first PR effort [​IMG] Any ideas? At no time did the amp clip or the Titanic show any signs of distress.

    I guess its time to go back to ports.

    [​IMG]
    [​IMG]
    [​IMG]
     
  2. Seth_L

    Seth_L Screenwriter

    Joined:
    Apr 5, 2002
    Messages:
    1,553
    Likes Received:
    0
    How were the PR's mounted in the box?
     
  3. Greg Conti

    Greg Conti Stunt Coordinator

    Joined:
    Mar 6, 2000
    Messages:
    71
    Likes Received:
    0
    The driver and PRs were all verticle. The driver facing the front, and the PRs on each side.
     
  4. Jason Dalton

    Jason Dalton Stunt Coordinator

    Joined:
    Feb 20, 2004
    Messages:
    174
    Likes Received:
    0
    Something isn't adding up.

    What were you playing that caused this?
     
  5. Mark Seaton

    Mark Seaton Supporting Actor

    Joined:
    Oct 10, 1999
    Messages:
    600
    Likes Received:
    0
    Also, what amplifier were you powering it with? A quick model I made in LspCAD suggested a real tuning point closer to 17Hz and possibility of tearing the PRs a very real possibility below 14Hz. This also presumes that the mass and volumes you noted are correct.
     
  6. Greg Conti

    Greg Conti Stunt Coordinator

    Joined:
    Mar 6, 2000
    Messages:
    71
    Likes Received:
    0
    Played some dance music for a while which I doubt did anything as the PRs didn't even move. Then a calibrated the sub output to about 80 db. Played test tones from 20 to 80 Hz at around 85 db and got a beautiful room response. Watched some scenes from Matrix Revolutions at -5db from ref levels. Seemed to handle it fine. Played some more tones and noticed one PR was going crazy while the other was barley moving. Pulled one of the PRs. The PR that was going crazy was the one that had the mass tube ripped off.
     
  7. Greg Conti

    Greg Conti Stunt Coordinator

    Joined:
    Mar 6, 2000
    Messages:
    71
    Likes Received:
    0
    Mark, I was using a bridged Adcom GFA555. I guess maybe Revolutions has some deep bass I wasn't counting on. Should have been using a subsonic filter I suppose. I thought the Titanic would give up way before the PRs would, at least from looking at the excursion graphs.
     
  8. Greg Yeatts

    Greg Yeatts Second Unit

    Joined:
    Feb 26, 2002
    Messages:
    300
    Likes Received:
    0
    I destroyed an Adire PR 15X myself. I think you might be making them a little too heavy. I think they are only rated for 1300 grams including the cone. I also destroyed the Dayton 12" DVC when I destroyed the PR15X. I was only using a 150 watt amp. I think it was because I clipped the amp. The spider on my PR15X and DVC 12" were both ripped rather impressively.

    First time I have ever broken a piece of audio equipment.
     
  9. Greg Conti

    Greg Conti Stunt Coordinator

    Joined:
    Mar 6, 2000
    Messages:
    71
    Likes Received:
    0
    I think I've come to the conclusion with Adires help that it must have been subsonics that killed the PRs. I ordered two more PRs and a 24db/octave subsonic filter. So much for saving money. But then if I had bought a sub, I wouldn't be having all this fun. It is pretty cool to show my friends the destroyed PRs :b Wish me luck [​IMG]
     
  10. Ryan Leemhuis

    Ryan Leemhuis Second Unit

    Joined:
    Oct 1, 2002
    Messages:
    490
    Likes Received:
    0
    quick question...on all speaker should there be a a filter to stop the speaker from receiving too low of frequencies? I imagine that would be taken care of by the receiver for a normal bookshelf.
     
  11. Greg Conti

    Greg Conti Stunt Coordinator

    Joined:
    Mar 6, 2000
    Messages:
    71
    Likes Received:
    0
    Correct. If the speaker are set to small on the receiver, then they would have the bass removed below the crossover point. That bass and any subsonic will now go to the sub. I think most powered subs have built in subsonic filters.
     
  12. Ryan Leemhuis

    Ryan Leemhuis Second Unit

    Joined:
    Oct 1, 2002
    Messages:
    490
    Likes Received:
    0
    do you have to worry about them if you were to set them to large? Not that I would I just want to make sure I don't damage the speakers I build!
     
  13. Greg Conti

    Greg Conti Stunt Coordinator

    Joined:
    Mar 6, 2000
    Messages:
    71
    Likes Received:
    0
    Well, people do blow woofers all time time in bookshelf speakers overdriving the bass driver but probably not from subsonic bass. I wouldn't say a subsonic filter is of much use on a bookshelf speaker. I don't think those drivers are going to respond to sub 20Hz signals. If the bookshelfs will be ported, a highpass filter at the port frequency may be a good idea. The reason I destroyed the passive radiators was because I problably fed them too much 10 to 15Hz and my sub did reproduce them.
     

Share This Page