PS3 HDMI connection to Infocus X10 problems

Discussion in 'Displays' started by DAZ-B, Mar 22, 2009.

  1. DAZ-B

    DAZ-B Auditioning

    Joined:
    Mar 22, 2009
    Messages:
    1
    Likes Received:
    0
    I am trying to connect my PS3 to an Infocus X10 using HDMI cable and getting a blank screen. I have made all the setting on both devices HDMI ready using a component cable but still no joy when I try switching to HDMI to view blu-ray discs. All suggestions or past experiences will be helpful, so please make a comment so I can see light at the end of the tunnel. My word!! the net is a big place to search!![​IMG]))) - DAZ-B
     
  2. Mike Prades

    Mike Prades Agent

    Joined:
    Mar 23, 2001
    Messages:
    34
    Likes Received:
    0
    Have you eliminated the HDMI cable as the culprit?

    I'm not familiar with the Infocus but are you able to cycle through the various inputs - component, HDMI, etc.?
     
  3. RANDY FISHER

    RANDY FISHER Second Unit

    Joined:
    Sep 1, 1998
    Messages:
    289
    Likes Received:
    0
    I just got one of these set up in place of my previous Sanyo last week. It is definitely finicky about how you configure the HDMI input. Basically you need to turn off the auto search function under the input settings. Then just pick HDMI as the input. In fact I turned off all the other inputs becase I am only using HDMI from my receiver. It locks on way to slow to the HDMI handshake and starts searching for other inputs before you get a successful handshake. When it starts searching for signals the source device gets an HDMI error. It's an ugly cycle. I have a PS3 and it works fine though it takes a bit longer to get an image up than my Sanyo did. Once you do though look out for a fantastic 1080p picture!
     
  4. Shad R

    Shad R Supporting Actor

    Joined:
    Oct 8, 2001
    Messages:
    537
    Likes Received:
    0
    This happened to my friend with his PS3. He checked out the Playstation website, and the first suggestion, reset the PS3 by holding the power button for 10 seconds, worked and he got a signal from HDMI. Check Playstations website for more troubleshooting.
     

Share This Page