No Sound: RCA HT In a Box

Discussion in 'AV Receivers' started by Steven Phipps, Apr 20, 2003.

  1. Steven Phipps

    Steven Phipps Stunt Coordinator

    Joined:
    Oct 3, 2001
    Messages:
    165
    Likes Received:
    0
    Real Name:
    Steve Phipps
    I know, before you start knocking it, a friend of mine could not care less about sound quality, got this unit for real cheap (DD Receiver & five speakers). I went to his home, hooked it all up and there is no sound. I am very experienced with HT, but just could not get sound, even from the tuner. There are no manuals with the unit, but something that strikes me as odd is there are little symbols on the side of the display which have the icons of the speaker outlay (which ones are on according to the DSP), and the fronts are constantly flashing, which leads me to believe there might have been a protect circuit interrupted or something, I would imagine they should just stay solid if there is a signal...ANY IDEAS??
     
  2. Jerome Grate

    Jerome Grate Cinematographer

    Joined:
    May 23, 1999
    Messages:
    2,978
    Likes Received:
    6
    If you are getting a flashing light from the power indicator, usually that means there's a power problem in reference to either clipping off because of a connection or inside the unit. Try disconnecting the speaker wires from the receiver and then turn it on. If the light still flashes, then I would take it back to the store for a replacement.
     
  3. Steven Phipps

    Steven Phipps Stunt Coordinator

    Joined:
    Oct 3, 2001
    Messages:
    165
    Likes Received:
    0
    Real Name:
    Steve Phipps
    It is not the power indicator, but the speaker indicatoers (what speakers the DSP is outputting to) that is flashing. But in 5.1 mode, they are all (6 indicators)solid without any sound. In stereo, they are flashing. Thanks for the reply.
     

Share This Page