Jump to content



Sign up for a free account!

Signing up for an account is fast and free. As a member you can join in the conversation, enter contests to win things like this Logitech Harmony Ultimate Remote and you won't get the popup ads that guests get. Click here to create your free account.

Photo
- - - - -

Problem with Denon AVR 1911


  • You cannot start a new topic
  • Please log in to reply
1 reply to this topic

#1 of 2 quartermoon

quartermoon

    Auditioning

  • 1 posts
  • Join Date: Oct 15 2012

Posted October 15 2012 - 04:18 AM

I've had this unit for about a year and haven't experienced any problems until yesterday. Turned it on in the morning and I had no sound/ no picture. Light is green on the reciever. I turned it off and then back on and still nothing. After several cycles, I did get sound, but still no picture. I then switched the receiver to another source (xbox) and there was again no sound or picture. I switched the receiver to HD radio and still no sound. I then did the factory reset and still no sound and/or picture (I'm using the HDMI ins and out). I did the reset again with the same result, including trying HD radio, and all the other sources. I took out my old receiver and hooked it up and all sources are outputing video/sound. Any ideas? Is the Denon toast?

#2 of 2 schan1269

schan1269

    HTF Expert

  • 12,612 posts
  • Join Date: Jul 04 2012
  • Real Name:Sam
  • LocationChicago-ish/NW Indiana

Posted October 15 2012 - 04:51 AM

Give it about 1-6 hours unplugged from the wall. That should dissipate any residual "brain" electricity... If it doesn't come back, then yes it likely is done. These things have micro-processors in them. Occasionally starving it of electricity is the only way to get a "fresh" re-boot.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users