1. Guest,
    If you need help getting to know Xenforo, please see our guide here. If you have feedback or questions, please post those here.
    Dismiss Notice

Problem with Denon AVR 1911

Discussion in 'AV Receivers' started by quartermoon, Oct 15, 2012.

  1. quartermoon

    quartermoon New Member

    Joined:
    Oct 15, 2012
    Messages:
    1
    Likes Received:
    0
    I've had this unit for about a year and haven't experienced any problems until yesterday. Turned it on in the morning and I had no sound/ no picture. Light is green on the reciever. I turned it off and then back on and still nothing. After several cycles, I did get sound, but still no picture. I then switched the receiver to another source (xbox) and there was again no sound or picture. I switched the receiver to HD radio and still no sound. I then did the factory reset and still no sound and/or picture (I'm using the HDMI ins and out). I did the reset again with the same result, including trying HD radio, and all the other sources.
    I took out my old receiver and hooked it up and all sources are outputing video/sound.
    Any ideas? Is the Denon toast?
     
  2. schan1269

    schan1269 HTF Expert
    HW Reviewer

    Joined:
    Jul 4, 2012
    Messages:
    17,041
    Likes Received:
    894
    Location:
    Chicago-ish/NW Indiana
    Real Name:
    Sam
    Give it about 1-6 hours unplugged from the wall. That should dissipate any residual "brain" electricity...
    If it doesn't come back, then yes it likely is done. These things have micro-processors in them. Occasionally starving it of electricity is the only way to get a "fresh" re-boot.
     

Share This Page