XP Remote Desktop controling HTPC - problems

Discussion in 'Archived Threads 2001-2004' started by BryanZell, Jan 31, 2003.

  1. BryanZell

    BryanZell Auditioning

    Joined:
    Jan 7, 2003
    Messages:
    3
    Likes Received:
    0
    I have a HTPC running in a closet and access it with the remote desktop tool in XP Professional. I use Media Jukebox to play MP3's on the remote machine. The problem is when I log in remotely and run Media Jukebox, it reports there is no audio device. If I log on at the machine and run Media Jukebox - no problem. It seems remote desktop does something funky with devices when logged in remotely. Any suggestions?
     
  2. Brian Ruth

    Brian Ruth Supporting Actor

    Joined:
    Jun 21, 2002
    Messages:
    563
    Likes Received:
    0
    Bryan:

    If you have your computers networked, I'd just share the folder where you have all your music on your HTPC.

    I do it that way for my home network, and I've never had a problem playing music on other computers. Worth a try. [​IMG]
     
  3. Tekara

    Tekara Supporting Actor

    Joined:
    Jan 8, 2003
    Messages:
    783
    Likes Received:
    0
    yeah, I'm gonna second that, share the music and run the files that way. devices become very odd when your linking computers as window sgets really confused as to where to look for the device.
     
  4. Max Leung

    Max Leung Producer

    Joined:
    Sep 6, 2000
    Messages:
    4,611
    Likes Received:
    0
    You need to turn off the Remote Desktop audio passthrough feature.

    When you run Remote Desktop Connection, you get the dialog box where you enter the IP address or name of the computer you wish to connect to. You will see an Options button. Click on it, then click on the Local Resources tab, then you will see a "Remote Computer Sound" drop-down box. Select "Leave on Remote Computer", and that should cause the remote PC to output the audio and not pass the audio data over the network.

    This is better than playing music through file-sharing, because you can turn off your PC and still have music piping through the remote machine.
     
  5. BryanZell

    BryanZell Auditioning

    Joined:
    Jan 7, 2003
    Messages:
    3
    Likes Received:
    0
    Thanks for the replys. I need to play the MP3's on the PC in the closet because it's connect to the receiver - I actually do have the MP3's on another comuter and share folders. Also, I have used the "Leave Sound on Remote Computer" option - it still causes problems. I can get this to work as long as I open Media Jukebox with the mouse attached to the remote PC, then remote desktop in. It just bothers me if I reboot, I need to go to the computer and open Media Jukebox - or whatever uses the sound card.
     

Share This Page