WindowsXP: Missing icons in SysTray!!!

Discussion in 'Archived Threads 2001-2004' started by Mike Veroukis, Dec 14, 2002.

  1. Mike Veroukis

    Mike Veroukis Second Unit

    Joined:
    May 8, 2001
    Messages:
    455
    Likes Received:
    0
    Location:
    Canada
    Real Name:
    Michael
    Hi everyone!

    This is a really strange problem and I could really use some help here. I've noticed many of the icons that normally appear in the SysTray no longer show up even though the process they're associated with is running in the Task Manager. Now, I know about the option to hide un-used systray icons, but I have that feature disabled! Therefore, the icons should always be displayed. I've also made sure that each application with a missing systray icon doesn't have any "disable systray icon" option enabled. As far as I can tell, the icons should be there!

    Now, I've found an odd fix to this, but it's not a real fix. When I boot up some icons are missing. If I Log-off and log-back in the icons re-appear. A reboot however does NOT fix the problem.

    Has anyone come across this sort of behaviour before? Is it fixable? I'm not too keen ro re-installing XP, but if I have to I will.

    Here's my setup:
    Windows XP Pro SP1 (with all updates and patches applied)
    ASUS A7V266 (wa)
    AthlonXP 1600+
    256MB DDR266 PC2100
    nVidia GeForce2 Ti 64MB (with latest detonator drivers)
    SMC network card

    Any ideas would be greatly appreciated. Thanks!

    - Mike
     
  2. Salvador

    Salvador Second Unit

    Joined:
    Dec 4, 2001
    Messages:
    431
    Likes Received:
    0
    I've experienced 'disappearing' sys tray icons. Most irritating is that my volume control icon dissapears at random times. I always use that but rebooting, enabling/disabling, or even formatting/reinstalling XP doesn't seem to get rid of the problem. I've given up and put the icon on my desktop for easy access.
     
  3. Mike Veroukis

    Mike Veroukis Second Unit

    Joined:
    May 8, 2001
    Messages:
    455
    Likes Received:
    0
    Location:
    Canada
    Real Name:
    Michael
     
  4. Jesse Leonard

    Jesse Leonard Second Unit

    Joined:
    Jun 8, 2000
    Messages:
    430
    Likes Received:
    0
    Are you sure that you don't have XP set to auto-hide system tray icons? This is one of the "features" of Windows XP:

    Auto Hide/Show System Tray Contents

    Have you ever wanted to just get rid of a system tray item, but not wanting to completely get rid of it? Or have you ever wanted to always see a certin icon in the System Tray? Well Its simple, and dosnt require any major editing on your part, and its completely safe. Just Do the Following:

    1. Right Click on start, and select 'Properties'

    2. Once in Properties, Select 'Taskbar'

    3. Find the 'Customize...' Button, and press it.

    4. Once the next screen comes up, find the icons you want/dont want. Click them, and click the drop down box. Here, you have two Options, Always Hide ( Hides It from the moment you start up, the the moment you shut down ) and Always Show ( Shows it even when it is inactive, will never "disapear" behind the arrow ). Select the option you want, and click ok. Do this to as many as you want.

    And thats it. It is that simple. Have fun, and happy tweaking!
     
  5. Mike Veroukis

    Mike Veroukis Second Unit

    Joined:
    May 8, 2001
    Messages:
    455
    Likes Received:
    0
    Location:
    Canada
    Real Name:
    Michael
    @Jesse,

    Thanks for the tip, but that was the first thing I tried. It makes no difference what I do with that settings. It's as if systray has a mind of it's own and no longer checks to see what I set it to. I have tried many things, I'm no stranger to computers (I'm a programmer by trade) I just can't figure out why this is happening! very frustrating! But thanks for your help.

    - Mike
     
  6. Mike Veroukis

    Mike Veroukis Second Unit

    Joined:
    May 8, 2001
    Messages:
    455
    Likes Received:
    0
    Location:
    Canada
    Real Name:
    Michael
    UPDATE:
    I have finally fixed the problem!!!! I posted the same question on TweakXP.com and I got a fix for this. I thought I'd post it here as well as some people might have the same problem.
    The solution was quite simple, just had to disable the UPnP. To do this I went into the control panel, selected Add/Remove programs, clicked on Add or Remove Windows Components (on the left hand side) and then selected Networking Services and clicked on Details and then unchecked the Universal Plug and Play option. That was it, after I rebooted it all worked fine. I never needed UPnP anyway so it's fine that I have it uninstalled, you could also simply disable the service. Anyway, that's that, I hope someone finds this useful.
    - Mike
     

Share This Page