Unreal Tournament 2003 Demo to be released today!

Discussion in 'Archived Threads 2001-2004' started by Scott DeToffol, Sep 13, 2002.

  1. Scott DeToffol

    Scott DeToffol Stunt Coordinator

    Joined:
    Oct 25, 2000
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    0
  2. Jason Harbaugh

    Jason Harbaugh Cinematographer

    Joined:
    Jul 30, 2001
    Messages:
    2,968
    Likes Received:
    0
    Trophy Points:
    0
    My cable modem is getting ready!! [​IMG]
     
  3. Dave F

    Dave F Cinematographer

    Joined:
    May 15, 1999
    Messages:
    2,885
    Likes Received:
    2
    Trophy Points:
    0
    Any suggestions for download locations that don't require an account?

    -Dave
     
  4. Ed E Lee

    Ed E Lee Agent

    Joined:
    Dec 21, 2001
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    0
     
  5. Kelley_B

    Kelley_B Cinematographer

    Joined:
    Feb 27, 2001
    Messages:
    2,324
    Likes Received:
    0
    Trophy Points:
    0
    downloading now!

    damn thing timed out at 36%!!! And I can't get back in!
     
  6. Dave F

    Dave F Cinematographer

    Joined:
    May 15, 1999
    Messages:
    2,885
    Likes Received:
    2
    Trophy Points:
    0
    Is it going to Usenet by any chance?

    -Dave
     
  7. MikeAlletto

    MikeAlletto Cinematographer

    Joined:
    Mar 11, 2000
    Messages:
    2,369
    Likes Received:
    0
    Trophy Points:
    0
    I was grabbing it at 26k/sec but now it seems to have stalled out. Stupid servers...if the server can't take the load the admins shouldn't be allowing the connections!!! I'm gonna wait till really late at night and try it again.
     
  8. Kelley_B

    Kelley_B Cinematographer

    Joined:
    Feb 27, 2001
    Messages:
    2,324
    Likes Received:
    0
    Trophy Points:
    0
    Ok all the bugs seem to have been fixed on fileplanet and i'm now d/ling at a steady 48.1KB. Gotta love personal servers at Fileplanet!
     
  9. MikeAlletto

    MikeAlletto Cinematographer

    Joined:
    Mar 11, 2000
    Messages:
    2,369
    Likes Received:
    0
    Trophy Points:
    0
    You only get 48.1KB on a personal server? What kind of connection do you have? I would expect it to be much faster...
     
  10. Kelley_B

    Kelley_B Cinematographer

    Joined:
    Feb 27, 2001
    Messages:
    2,324
    Likes Received:
    0
    Trophy Points:
    0
    cable, but the personal servers are getting just as hammered as the standard ones.
     
  11. Ed E Lee

    Ed E Lee Agent

    Joined:
    Dec 21, 2001
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    0
    Everything is getting whacked around like a tissue in a wind tunnel. I think for most people, you're better off getting some sleep and trying in the morning. [​IMG]
    I got on some server, and I'm humming along at 26.3KB with my DSL. 47% and counting. [​IMG]
     
  12. Kelley_B

    Kelley_B Cinematographer

    Joined:
    Feb 27, 2001
    Messages:
    2,324
    Likes Received:
    0
    Trophy Points:
    0
    i just finished the install fixing to go play!
     
  13. Mike_G

    Mike_G Screenwriter

    Joined:
    Jun 1, 2000
    Messages:
    1,477
    Likes Received:
    15
    Trophy Points:
    0
    Real Name:
    Mike
    Downloading it now. 53%.
    I'm such a UT whore.
    As soon as I get it down, I'll see if any of you want to try and kick my ass [​IMG]
    (emphasis on the word 'try').
    I was going to pick up the Radeon 9700 and decided against it. Of course, I found out about this AFTER CC closed [​IMG].
    Mike
     
  14. Dave F

    Dave F Cinematographer

    Joined:
    May 15, 1999
    Messages:
    2,885
    Likes Received:
    2
    Trophy Points:
    0
    Oh baby, I almost forgot how good the UT lovin' was. [​IMG]
    Can't wait for ship date!
    -Dave
     
  15. Mike_G

    Mike_G Screenwriter

    Joined:
    Jun 1, 2000
    Messages:
    1,477
    Likes Received:
    15
    Trophy Points:
    0
    Real Name:
    Mike
    Ok, I'm in. Where is everybody? [​IMG]
    Mike
     
  16. Kelley_B

    Kelley_B Cinematographer

    Joined:
    Feb 27, 2001
    Messages:
    2,324
    Likes Received:
    0
    Trophy Points:
    0
    Just got done playing.......maybe QuakeCon and seeing Doom III in person just jaded me, but I am not impressed at all with this game. It just looks like.....Unreal/Unreal Tournament.
     
  17. Sean Oneil

    Sean Oneil Supporting Actor

    Joined:
    Mar 19, 2001
    Messages:
    931
    Likes Received:
    0
    Trophy Points:
    0
    I was not too hot for it either. For me it was just completely missing that something special that the first UT had..
    I'm off to go play UT 1 again [​IMG]
     
  18. Sean Moon

    Sean Moon Cinematographer

    Joined:
    Jan 25, 2001
    Messages:
    2,041
    Likes Received:
    0
    Trophy Points:
    0
    Game looks good overall, plays decent. Lacks the character that UT had though. Also feel bad just barely meeting the system requirements on this thing now. UT is a dreamboat running on my system, but 2003 runs a little choppy. Too broke to upgrade though.
    The voices and taunts on this game are a little lame. The game overall so far is not jazzing me up like I thought it would.

    Also...I cant get the HUD to appear.
     
  19. Mike_G

    Mike_G Screenwriter

    Joined:
    Jun 1, 2000
    Messages:
    1,477
    Likes Received:
    15
    Trophy Points:
    0
    Real Name:
    Mike
    Same here. I'm very underwhelmed.

    It looks SO much like a Quake III clone.

    UT2K3 doesn't have the uniqueness UT had.

    Mike
     
  20. Graeme Clark

    Graeme Clark Cinematographer

    Joined:
    Jan 5, 2000
    Messages:
    2,180
    Likes Received:
    0
    Trophy Points:
    0
    I got it from the Homelan link in about 5 minutes. Was going at about 400k (and I don't usually see much faster). I was rather impressed.

    I never played the original UT, but this game feels like a polished Quake 3 with some cooler weapons. Bomber run could be rather fun though.

    Is it just me or is the in game browser not working?
     

Share This Page