Under Powered Sub?

Discussion in 'Archived Threads 2001-2004' started by RonaldO, Mar 4, 2003.

  1. RonaldO

    RonaldO Auditioning

    Joined:
    Mar 4, 2003
    Messages:
    3
    Likes Received:
    0
    First my setup: Onkyo 5:1 65watts, Boston tower fronts, JBL center. My wife bought me a small RCA 50 watt 8" sub, I connected it to my sub out and to the subs line level rca in using a "Y" connector. The bass of my system dropped by 50% and I could barely even hear the sub. Was it the sub just vastly under powered or should I not use the line level output?
     
  2. Lee Carbray

    Lee Carbray Second Unit

    Joined:
    Oct 23, 2002
    Messages:
    308
    Likes Received:
    0
    Did you adjust the volume of the sub at all? and how did you set it up in the receiver? You should be using the line level so that is ok.
     
  3. RonaldO

    RonaldO Auditioning

    Joined:
    Mar 4, 2003
    Messages:
    3
    Likes Received:
    0
    yes, the sub volume was at full blast and the Onyko has three different sub settings, nothing ever boosted the bass. I have more bass without the sub then with. Think I should try a JBL 10" 150Watt?
     
  4. JeremyFr

    JeremyFr Supporting Actor

    Joined:
    Jan 28, 2003
    Messages:
    794
    Likes Received:
    0
    did you by chance check to see if you had the phase set correctly on the sub, if you're not getting any bass you may have it out of phase with your main speakers which would cancel nearly all audible bass. Also I would ditch the RCA and go with something like a JBL myself to answer that question.
     
  5. RonaldO

    RonaldO Auditioning

    Joined:
    Mar 4, 2003
    Messages:
    3
    Likes Received:
    0
    yup checked the phase, and i did ditch the rca lol
     
  6. Donnie Eldridge

    Donnie Eldridge Supporting Actor

    Joined:
    Jan 3, 2001
    Messages:
    761
    Likes Received:
    0
    Also, make sure you change your receiver settings to small speakers.
     

Share This Page