1. Sign-up to become a member, and most of the ads you see will disappear. It only takes 30 seconds to sign up, so join the discussion today!
    Dismiss Notice

Surround Speakers with Hissing

Discussion in 'Archived Threads 2001-2004' started by Chito Deinla, Jan 31, 2002.

  1. Chito Deinla

    Chito Deinla Auditioning

    Joined:
    Dec 20, 2001
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Recently I acquired DVD player (Pioneer) and enjoyed truly Dolby Surround using my Phillips - ESI Enhanced Prologic Receiver. However I noticed that there's hissing sound coming from the Surround speakers everytime I played DVD movies. My speakers are all Phillips (including surround). By the way i'm using ordinary copper wire connection which I think could be the culprit.

    Do I have defective surround speakers? Will appreciate your help and advice. Thank you.
     
  2. Todd Hostettler

    Todd Hostettler Second Unit

    Joined:
    Jun 7, 1999
    Messages:
    283
    Likes Received:
    0
    Trophy Points:
    0
    I used to have the same problem with my Denon. Recently upgraded my wiring to 12 ga Sound King cable and - guess what? - it disappeared.

    YMMV.
     
  3. Bill Leber

    Bill Leber Stunt Coordinator

    Joined:
    Aug 25, 2001
    Messages:
    133
    Likes Received:
    0
    Trophy Points:
    0
    I had a similar problem with my Onkyo. Unshielded interconnects were to blame. Whether it's the speaker cable or the interconnects, I'm sure you're picking up some kind of interference.
     

Share This Page