Surround Mode Indicator

Discussion in 'Archived Threads 2001-2004' started by Lando P, Nov 26, 2002.

  1. Lando P

    Lando P Agent

    Joined:
    Apr 15, 2002
    Messages:
    40
    Likes Received:
    0
    On my AVR-510's front panel surround mode indicator, the "Dolby Digital" light would stay on only for a couple of minutes after I turned the receiver on. Then the light would go off while the rest remain lit.

    The unit's still under warranty, but the wait of 10 - 14 days plus the inconvenience of taking out and putting back all the cable and wire connections is just too much for a supposedly minor problem like this.

    Has anyone had a similar problem? Or does anybody have any idea whether this could be a DIY fix? I would appreciate your input.

    Regards
     
  2. Brian Ruth

    Brian Ruth Supporting Actor

    Joined:
    Jun 21, 2002
    Messages:
    563
    Likes Received:
    0
    Lando:

    Are you sure that a Dolby Digital signal is still being fed into the receiver after the light goes out?
     
  3. Lando P

    Lando P Agent

    Joined:
    Apr 15, 2002
    Messages:
    40
    Likes Received:
    0
    Yes, and before this problem showed up, even if it's another format/mode like DTS or Logic 7, the "Dolby Digital" mode indicator would stay lit while the receiver was on.

    Thank you.
     
  4. JackS

    JackS Supporting Actor

    Joined:
    Jan 17, 2002
    Messages:
    634
    Likes Received:
    0
    Lando- Check the OM, this might be an option for the display that you overlooked. Also the DD indicator should blink out during DTS or other non DD source. You might try cycling through the display mode on your remote if uou have this function. Hopefully it's somthing simple that you're overlooking. Good luck
     

Share This Page