Subwoofer hum! Help me.

Discussion in 'Archived Threads 2001-2004' started by Doug_H, Nov 3, 2001.

  1. Doug_H

    Doug_H Supporting Actor

    Joined:
    Mar 21, 2000
    Messages:
    586
    Likes Received:
    0
    I started getting a hum in my subwoofer today. I have traced it to either the 6 channel output on my DVD Player or the input on the receiver.
    I have already changed out the cables and if the subwoofer cable between the player and receiver is pulled the hum goes away.
    I have had this set up for several months so I am at a loss. I have a Rotel power conditioner so I doubt it is a power problem.
    Any help is greatly welcomed.
    ------------------
    The Mischievous Rogue Strikes Again! The Humble Hanson Theater
    [Edited last by Doug_H on November 03, 2001 at 08:00 PM]
     
  2. Doug_H

    Doug_H Supporting Actor

    Joined:
    Mar 21, 2000
    Messages:
    586
    Likes Received:
    0
    OK, it went away on it's own but that has me even more worried. I am sure someone here has had this problem before. Please help.
     
  3. Bob McElfresh

    Bob McElfresh Producer

    Joined:
    May 22, 1999
    Messages:
    5,182
    Likes Received:
    0
    If it happens again, adjust the system so you hear the humm, then disconnect the CATV cable. This might be your source of humm and it bypasses your power conditioner.
    I would also suggest that you carefully un-plug and re-connect all your interconnects. I cannot explain why, but a loose RCA plug sometimes allows noise into the system. Periodic un-plug and re-connect is not a bad thing to do.
     

Share This Page