What's new

Sub Woofer Static (1 Viewer)

Jamie Murphy

Auditioning
Joined
Oct 11, 2016
Messages
2
Real Name
Jamie Murphy
Just recently started getting some static from my Omage 10" powered home theatre sub. It's only occasional and not overly loud. I am running with a Yamaha HTR-6190 Receiver. Pioneer Centre Channel, Pro-Linear surround speakers. I am convinced that it is isolated to the subwoofer itself as the static sound is present with the RCA unplugged, the receiver turned off. From what I have been reading lately, it may be caused by electro static because of dryer air now that the gas furnace is heating the home. That seems a little far fetched as the sub is about 7 years old and has never had this issue before. I am willing to replace the sub just as long as I can positively fault the old one as the issue.
 

Craig Chase

Gear Guru
Joined
Oct 21, 2002
Messages
1,774
Location
Pennsylvania
Real Name
Craig
It sounds like the amp may be on its way out. You probably have some time left, but you may want to start shopping now. :)
 

Jamie Murphy

Auditioning
Joined
Oct 11, 2016
Messages
2
Real Name
Jamie Murphy
You were right, the amp lasted about 2 more days after my post, then there was nothing left of it. Wife was nice enough to pick me up a Klipsch Sub12. Wow does this thing pound. Night and day compared to my old little sub. have my receivers sub output at -5 and it shakes the house.
 

Users who are viewing this thread

Sign up for our newsletter

and receive essential news, curated deals, and much more







You will only receive emails from us. We will never sell or distribute your email address to third party companies at any time.

Latest Articles

Forum statistics

Threads
357,597
Messages
5,141,238
Members
144,419
Latest member
Azy
Recent bookmarks
0
Top