Sub amp popping noise

Discussion in 'Archived Threads 2001-2004' started by BrianF, Dec 6, 2002.

  1. BrianF

    BrianF Stunt Coordinator

    Joined:
    Oct 18, 2002
    Messages:
    62
    Likes Received:
    0
    My current setup is a H/K AVR525 receiver going to my sub amp to my sub. The amp is a Crown CE1000 and my sub is the Dayton DVC 15. I have an adapter to change the RCA connector on the sub out cable to a phono jack for inputing into the Crown amp. I've also changed the input sensitivity on the Crown amp to .775V.


    The problem is that everytime the receiver changes sound modes (which occurs several times before a DVD movie starts, or when changing sources, powering receiver up/down etc.) I get a popping noise from my sub. Aside from being EXTREMELY annoying will this popping noise cause damage to my sub? Is this something that occurs with Crown amps or is mine faulty? I've never experienced this before with any of my subs or amps. How can I stop this from occurring?
     
  2. BrianF

    BrianF Stunt Coordinator

    Joined:
    Oct 18, 2002
    Messages:
    62
    Likes Received:
    0
    Well I returned the Crown amp and went back to my Radio Shack 100 Watt amp. No popping noises and speaker hum now. I'll be getting a different amp eventually to have better head room but for now it seems to work fine.
     
  3. Kim Cadiz

    Kim Cadiz Auditioning

    Joined:
    Jun 28, 2002
    Messages:
    2
    Likes Received:
    0
    i am also experiencing a popping sound with my current set up. Everytime I switch off the sub woofer M&K the popping sound goes with it
     

Share This Page