Serious Subwoofer HUM

Discussion in 'Speakers' started by Johnny Ayala, Dec 3, 2003.

  1. Johnny Ayala

    Johnny Ayala Stunt Coordinator

    Joined:
    Nov 13, 2003
    Messages:
    183
    Likes Received:
    0
    I have a JBL PSW1200 subwoofer, and just today, when I went to turn off my receiver, the sub started making a really really loud hum, like feedback. This in turn made all of the speakers do the same thing. The sub was connected to the receiver via the sub output of the receiver. I tried connecting it via the speaker outputs.and it still did the same thing. Finally I disconnected the sub alltogether, and the humming stopped. This was only happening
    AFTER the receiver was turned off. Any ideas? Thanks.......Johnny [​IMG] [​IMG]
     
  2. saprav

    saprav Auditioning

    Joined:
    Mar 30, 2003
    Messages:
    5
    Likes Received:
    0
    I don't mean to jinx you , but the last time this happened to me - my JBL sub blew.

    If you do a search on avs or audioreview, you'll find a ton of people who've had problems with the JBL subs.

    I sent a message to JBL and they replied with - contact your nearest JBL authorized service center.

    In your case, I hope this is not the case, but I've seen this happen too many times.

    I purposely went with an SVS this time around.

    I currently use my JBL as an end-table.

    VSapra [​IMG]
     
  3. Johnny Ayala

    Johnny Ayala Stunt Coordinator

    Joined:
    Nov 13, 2003
    Messages:
    183
    Likes Received:
    0
    End table huh? Mine will better be used as a new pot for my plant. Thanks, this isnt the first time I've heard this about JBL's. [​IMG][​IMG]
     

Share This Page