Red horizontal lines across Mitsubishi when it turns on...

Discussion in 'Displays' started by Kenneth Harden, Sep 11, 2005.

  1. Kenneth Harden

    Kenneth Harden Screenwriter

    Joined:
    May 13, 2002
    Messages:
    1,365
    Likes Received:
    0
    ...we got a 52" Mitsubishi (WD-52528) and sometimes, when you first turn it on, there are about 100 thick red horizontal lines across the screen that stay there for between 15 seconds and a few minuites. It is not the source, but something in the TV.

    Any ideas?
     
  2. Timon Russo

    Timon Russo Stunt Coordinator

    Joined:
    May 10, 2000
    Messages:
    213
    Likes Received:
    0
    Kenneth, I don't know what that is specifically - but on my Mits WS65807, I had something similar.

    When I first got it, there was a defect in the green crt and I had it replaced. The new one seemed to display faint green circles expanding out from the center, until it warmed up about a minute later.

    That problem went away in about a month, and now there are now picture problems 4 years later.
     
  3. John Whittle

    John Whittle Stunt Coordinator

    Joined:
    Mar 22, 2004
    Messages:
    185
    Likes Received:
    0


    If it's under warranty, get a service call and make sure it's detailed on your complaint. If they can't find it now or fix it now, that'll come in handy later if you have a problem out of warranty.

    This could be a problem in the red channel but it really takes a service call to check it out (and they may know about it already).

    John
     

Share This Page