reciever trouble

Discussion in 'AV Receivers' started by Chris Floyd, Jan 25, 2006.

  1. Chris Floyd

    Chris Floyd Auditioning

    Joined:
    Oct 11, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Back in August my Durabrand ht-395 was hit by lightning. When I turn it on all I hear is a very load noise. I checked all the fuses and there fine. I looked inside and saw nothing that looked burnt. I contacted lenoxx and they said it was the output transistor. Does this sound right? Also if I go about replacing it what does it look like and what will I need to replace it myself?
     
  2. Jasen Chandler

    Jasen Chandler Stunt Coordinator

    Joined:
    Sep 16, 2001
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    0
    IMO, by the time you spend the time and money to fix it yourself you could have bought another durabrand theater unit. I would ask the manufacturer how much they'd fix it for.
     
  3. Chris Floyd

    Chris Floyd Auditioning

    Joined:
    Oct 11, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    They told me $30 for them to fix it. I thought about buying a new one but the model I have I can't find.Just the one with the dvd player which has only one other connector.
     
  4. Chris Floyd

    Chris Floyd Auditioning

    Joined:
    Oct 11, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Just an update. I found out it's mounted against the silver heatsink. When I unscrew it it won't come off. How do I remove it?
     

Share This Page