What's new

Radeon 8500 problem in DX games - FFXI, UT2004 (1 Viewer)

DaveGTP

Senior HTF Member
Joined
Jul 24, 2002
Messages
2,096
Hey guys,
I've got a Radeon 8500 and it is acting really funny in DirectX games. In FFXI (just bought) and UT2004 demo, I get weird planes and horizontal lines coming out of nowhere. I have tried driver update, DirectX update, playing with AA and other settings, to no avail. Any suggestions?
 

DaveGTP

Senior HTF Member
Joined
Jul 24, 2002
Messages
2,096
I'm really beginning to think that this is a heat issue. I cleaned out the Radeon's fan - it had a lot of fuzz in it. I also underclocked it a few mhz using powerstrip. Now it seems to run better - it takes longer for the artifacts to show up.
 

Joe Hsu

Supporting Actor
Joined
Jul 2, 2001
Messages
812
Definitely a cooling issue if you're not OCing it and have proper drivers...have you tried running the system with the side open and see if it still does that? You could always try an aftermarket cooling unit.
 

DaveGTP

Senior HTF Member
Joined
Jul 24, 2002
Messages
2,096
I ran it side open for a bit, but it was still pretty hot when I did it. I think I will try to clean it with a can of air and see if that helps. The suggestion for an aftermarket cooling kit is a good one, I might try that if cleaning doesn't do the job.
 

DaveGTP

Senior HTF Member
Joined
Jul 24, 2002
Messages
2,096
Cleaning the card didn't do any good. It still is acting funny, with crazy planar artifacts popping out of surfaces. I noticed that now C&C Generals it doing it too -whereas before it wasn't.

So much for my month trial of FFXI.

Any other thoughts? I knew I needed an upgrade, but we are buying a house this month (closing on Sep 3) so it's pretty bad timing to be doing an upgrade...
 

Users who are viewing this thread

Forum Sponsors

Forum statistics

Threads
346,881
Messages
4,793,797
Members
141,924
Latest member
ixlr8
Top