PS2 and Dolby Digital (Newbie Question!)

Discussion in 'Archived Threads 2001-2004' started by AndrewDavid, Nov 28, 2002.

  1. AndrewDavid

    AndrewDavid Auditioning

    Joined:
    Nov 27, 2002
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hello all! I'm new to the forum, but I hope you can help me out with my question!

    I recently bought a Sony HTIB (HT-DDW740 Receiver w/sub and 5 speakers) and am temporarily using my PlayStation 2 as my primary DVD player. I bought an optical cable to run the digital audio signal from my PS2 to the Video 2 input on my receiver. I also switched the audio out in the PS2 menu to "optical out" and the signal gets their fine... but uses Dolby Pro Logic to decode it, even when playing movies with the Dolby 5.1 option chosen!

    I tried (what I think is) everything. Such as changing the "autodetect", "mode", etc. But that damn little "D DIGITAL" or "DTS" never lights up... all I see is the "PRO LOGIC" and "OPT" (for optical source signal). Can somebody please help me? Thanks so much in advance!

    ...and Happy Thanksgiving!

    Andrew
     
  2. Vince Maskeeper

    Vince Maskeeper Producer

    Joined:
    Jan 18, 1999
    Messages:
    6,499
    Likes Received:
    0
    Trophy Points:
    0
    Andrew,

    I don't have a PS2- but most DVD players have a digital audio option in addition to selecting the output. Once the digital output is selected- many DVD players have an option to pass DD/DTS as a native bitstream or to convert it to a 2 channel PCM stream for older receivers which can't handle the dolby/dts signal.

    I'm sure a PS2 owner might pipe up about this-- but in the meantime- I'd look for a setting for digital audio output-- might toggle between Bitstream/PCM... make sure it's on bitstream.

    -V
     
  3. Hugo

    Hugo Stunt Coordinator

    Joined:
    Nov 21, 2002
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    0
    Hi,
    I have the same question as Andrew. Can anyone helps us? Thanks!!!

    Hugo
     
  4. BrentPollard

    BrentPollard Second Unit

    Joined:
    Dec 18, 2001
    Messages:
    445
    Likes Received:
    0
    Trophy Points:
    0
    Vince is correct, I can't get to my PS2 at the moment but you must go into the menue and select between Dolby Digital and PCM.[​IMG]
     
  5. Hugo

    Hugo Stunt Coordinator

    Joined:
    Nov 21, 2002
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    0
    I already did that with no success.

    Hugo
     
  6. Vince Maskeeper

    Vince Maskeeper Producer

    Joined:
    Jan 18, 1999
    Messages:
    6,499
    Likes Received:
    0
    Trophy Points:
    0


    I'm not sure exactly what else you've tried since you dropped into this thread in the middle... but make sure:
    1) The player (PS2 in this case) is connected to the receiver with a digital connection. I would suggest disconnecting the red/white analog audio cables- just to make sure.
    2) The player has the digital output enabled and set to pass the data as BITSTREAM and not pcm (some just have a toggle for DD and DTS ON/OFF- make sure it's on). Double check. Triple check.
    3) The digital input on the receiver is assigned to the proper input and is enabled. Make sure the receiver shows a DIGITAL signal is coming in.
    4) The disc in the player actually has a 5.1 soundtrack. Not all DVDs have 5.1 tracks- and "dolby digital" doesn't mean 5.1. Make sure you have gone to the setup menu and selected the 5.1 sountrack.
    5) All processing it turned off. Some receivers allow you to apply some processing to 5.1 material- make sure the receiver is set to playback the native format.

    -Vince
     
  7. AndrewDavid

    AndrewDavid Auditioning

    Joined:
    Nov 27, 2002
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    EUREKA!!!

    Yes... there is an option on the PS2 (which, strangely enough, you can only access while a DVD is inserted) allowing you to change the Dolby Digital to "ON" and the DTS to "ON". Changing the output to optical was not enough. Now it sounds awesome! Thanks for the advice!

    Andrew
     
  8. Vince Maskeeper

    Vince Maskeeper Producer

    Joined:
    Jan 18, 1999
    Messages:
    6,499
    Likes Received:
    0
    Trophy Points:
    0
    Enjoy!

    Oh, and wlecome to the forum...

    -V
     

Share This Page