1. Sign-up to become a member, and most of the ads you see will disappear. It only takes 30 seconds to sign up, so join the discussion today!
    Dismiss Notice

problems with H/K 320

Discussion in 'AV Receivers' started by kuttaS, Dec 13, 2003.

  1. kuttaS

    kuttaS Stunt Coordinator

    Joined:
    Jul 21, 2003
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    0
    i finally got a HK 320 off ebay for $256. my friend once told me that there is a certain production problem witht the HK 320 and i cant remember it. also he told me that if i call HK and say that i have that problem, they will replace mine with a new unit (HK330). so can you guys tell me what is the problem with the HK 320s?
     
  2. Baldemar Garcia

    Baldemar Garcia Stunt Coordinator

    Joined:
    Feb 4, 1999
    Messages:
    141
    Likes Received:
    0
    Trophy Points:
    0
    The main problem is that some units have a Logic7 decoding problem. When setup for a 7.1 system, there will be no useable output on the SBR (surround back right) preamp output. I verified that mine suffers from this problem. However, this problem is now serviceable at your nearest HK authorized service center, so no more swapping for a newer model [​IMG] BUT, my local sc did not believe that HK's service bulletin would actually fix that particular problem, so they didn't implement it and my receiver is still defective. I'll just stay with 5.1. HK assures me that the service bulletin will indeed fix this problem.

    There is also one other minor issue. Logic7 will randomly go a little nutty, requiring a cycling of surround modes to get back on track.
     

Share This Page