Problem with scanner

Discussion in 'Archived Threads 2001-2004' started by Alf S, Sep 27, 2002.

  1. Alf S

    Alf S Cinematographer

    Apr 23, 2000
    Likes Received:
    Real Name:
    I've got a 3 year old Canon 620U USB scanner that has work flawlessly for all these years. I haven't scanned anything in a month or so, and yesterday I went to scan some pics, and I got the message "Cannot communicate with scanner, it may be unplugged etc etc"

    I checked all connections, power, etc..and nothing appears wrong. I unplugged the scanners USB and plugged it back in, and I didn't get any message on the screen that usually pops whenever a USB device is plugged in saying "device found".

    I went so far as to uninstall everything related to the scanner, unplugged everything, shut down, and reinstalled, yet nothing. However,if I go to device manager, it shows the Canon 620P in the imaging folder,and it says device is running properly.

    I even went to Control Panel and clicked on "Scanners" and it doesn't show the Canon and won't let me "Add scanner"

    What could have gone wrong?? Any suggestions? I don't want to have to buy another scanner if at all possible.

    Thanks in advance
  2. Randy_T

    Randy_T Stunt Coordinator

    Dec 18, 2001
    Likes Received:
    I had the same problem with a Cannon 650U running Windows 98SE. I believe the USB controller in Windows 98 is very flakely. Everything I tried didn't work. About 3 months ago, I installed Windows XP and decided to try installing the scanner again. It's been working great ever since.
    If you have a AMD Processor or a VIA Technologies USB Controller, go
    HERE for an update from Microsoft.
    Randy T

Share This Page