Problem with PS3 and Onkyo 604

Discussion in 'Playback Devices' started by Nick Graham, Apr 29, 2007.

  1. Nick Graham

    Nick Graham Screenwriter

    Oct 16, 2001
    Likes Received:
    Posted this on AVS as well, hoping to find some answers :

    I picked up an Onkyo 604 a while back to go with my PS3, but I've been having a strange audio problem with in in regards to Blu-Ray playback. Many times I will put in a Blu-Ray movie, and there will be no audio, be it in the menu or in the movie itself. The only way I've found to remedy this is to turn the receiver off, and then back on. Back when I only owned one or two Blu-Ray titles, it was a small inconvenience, but with my Blu-Ray purchases starting to approach the number of my HD purchases, it's becoming more of a nuisance. Would setting the audio output to linear PCM instead of bitstream effect titles that are encoded with plain old Dolby Digital or DTS, and will it downmix them into 2.0 PCM?

    My first thought was to wait until there were affordable players in the fourth quarter that decoded TrueHD and DTS-MA, but I know at some point as a gamer the PS3 will eventually have games for it that I want to play (and hopefully they will have 1080i upscaling for said games).

    I know the 604 is a pretty popular receiver for low price HDMI audio goodness- has anyone else experienced this problem?
  2. Gabe D

    Gabe D Cinematographer

    May 16, 2001
    Likes Received:
    I have the Onkyo 674 and have had the same problem. (Not every time, but sometimes.) I don't know if it's the receiver or the PS3. I am very interested to hear if anyone knows the cause of the problem.
  3. John Garcia

    John Garcia Executive Producer

    Jun 24, 1999
    Likes Received:
    Real Name:
    Since the 604 is HDMI 1.1, yes it should be set to LPCM.

Share This Page