Powered Sub Transformer Hum

Discussion in 'Speakers' started by William_Morr, Sep 14, 2003.

  1. William_Morr

    William_Morr Extra

    Joined:
    Aug 21, 2002
    Messages:
    24
    Likes Received:
    0
    I have a powered subwoofer that has 60 hz transformer hum. This hum occurs simply by plugging it into an outlet and not having the interconnect attached. The transformer is firmly seated and the power cord is two prong. I took it apart yesterday and separated the components. When I took the transformer out of the enclosure, thus separating it from the driver, the hum went away.

    Two questions:

    Any ideas on how to shield the transformer from the driver magnets (the driver has a bucking magnet for shielding)?

    How would I go about replacing the transformer?
     
  2. ScottCarr

    ScottCarr Second Unit

    Joined:
    Jan 28, 2003
    Messages:
    459
    Likes Received:
    0
    Have you tried using an outlet on a differnet circuit than the rest of your audio and video equipment?

    What kind of sub?

    Also try doing a search on the various forums on "ground loop"

    scott
     
  3. Wayne Ernst

    Wayne Ernst Cinematographer

    Joined:
    Feb 24, 2002
    Messages:
    2,588
    Likes Received:
    0
    My sub used to experience hum. I was able to get around the issue buy utilizing a better insulted subwoofer cord.

    However, it sounds like a ground loop is causing your issue. Search for ground loop, invoke the changes ... and enjoy your peaceful music.
     
  4. William_Morr

    William_Morr Extra

    Joined:
    Aug 21, 2002
    Messages:
    24
    Likes Received:
    0
    Thanks for the advice guys but I don't think it's ground loop. It exhibits the hum no matter what outlet it's plugged into, it's a two-prong plug and it hums without being connected to any signal source. I thought it was significant that it doesn't hum when the transformer is out of the enclosure.
     
  5. quyen_nguyen

    quyen_nguyen Auditioning

    Joined:
    Aug 26, 2003
    Messages:
    8
    Likes Received:
    0
    Hi Willian

    Do you know what type of hum do you have, whether the hum was generate from transformer or the hum you can hear thru your speaker?

    1. If it is transformer hums, buy some grommet to place between transformer and amplifier's panel (or whaterver the xformer mounted to). Most the time, when you have this type of hum and if you hold transformer on you hand without anything touching the transformer but your hand, then you should not hear this hum at all.

    2. If there is 60hz hum which you can hear on your speaker only (Flux from transfomer) all you have to do is keep the transformer away from speaker/passive-xover, that will taking care that hums. If you don't have room to keep your transfomer away from driver, then buy a flux shield for your transfomer. Another way you can improve this hums is rotate your transformer around to see what is the best position (weekest flux) of the xformer cause less hum

    Good luck
     
  6. Greg_R

    Greg_R Screenwriter

    Joined:
    Apr 9, 2000
    Messages:
    1,996
    Likes Received:
    0
    Location:
    Portland, OR
    Real Name:
    Greg
    This is probably not a ground loop (2 prong cord, makes a hum even if signal cable isn't plugged in, etc.).

    Is there any reason why you haven't contacted the manufacturer or your dealer to have them fix it?

    Why not mount the transformer externally and run wires into the sub to connect to the driver? Fully enclose the amp if you have kids or pets.
     
  7. William_Morr

    William_Morr Extra

    Joined:
    Aug 21, 2002
    Messages:
    24
    Likes Received:
    0
    I've sent the amp and transformer back to the manufacturer. They replaced the caps which did nothing for the hum. The hum is coming from the speaker. I'm going to try and shield the transformer with flux shield sa guyen suggests. Thanks guys.
     

Share This Page