Please Help: Buzzing Sound From My Pioneer After Getting Warm

Discussion in 'AV Receivers' started by JasonMB, Apr 5, 2004.

  1. JasonMB

    JasonMB Auditioning

    Joined:
    Nov 23, 2002
    Messages:
    3
    Likes Received:
    0
    After about 15 minutes of use, my Pioneer VSX-D409 starts to make a very annoying buzzing sound that emanates from the receiver itself. I know it's not the most expensive receiver, but it's only about 3 years old. Is this a transformer problem or something else? Can I fix it myself? Thanks![​IMG]
     
  2. AndrewErickson

    AndrewErickson Stunt Coordinator

    Joined:
    Aug 13, 2003
    Messages:
    128
    Likes Received:
    0
    Possibly a transformer? I don't know your electronics expertice but I would suggest just living with it or throwing it away and getting a new receiver.
     
  3. Chu Gai

    Chu Gai Lead Actor

    Joined:
    Jun 29, 2001
    Messages:
    7,270
    Likes Received:
    1
    My guess is that it could very well be the power supply or some other loose component. One needs to be very careful and I do mean VERY careful when opening up the cover to look inside so as to not get shocked or worse. Myself, I'd open it and try to isolate which component it is. Then let's say it's the PS. I'd turn the receiver off and unplug it for a couple of hours. The PS is afixed to the chassis with some sort of mounting screws that may've come loose (tighten in that case) or there may be a small rubber bushing that's deteriorated (replace it with something similar). Other than that it's a trip to the repair shop.
     

Share This Page