Pee-Wee's Playhouse Christmas Special Issues

Discussion in 'TV on DVD and Blu-ray' started by Brandon.B, Nov 20, 2005.

  1. Brandon.B

    Brandon.B Stunt Coordinator

    Joined:
    Oct 26, 2005
    Messages:
    125
    Likes Received:
    0
    I picked up Pee-Wee's Playhouse Christmas Special on DVD yesterday and when I put it in the player, I noticed there was a lot of pixilation throughout the DVD in different parts and when going to the chapter selections, the little previews in each ornament were all pixilated and were skipping like crazy. I have a Toshiba SD-430VSC.

    I thought it was the DVD, so I returned it and got a new copy. Put it in, same thing is happening. However, the DVD works on the Hitachi DVD/VCR player I have. I also noticed the DVD is region 0. Could this have anything to do with it? Just wondering why it would only be happening with this DVD. Its region was all I could think of and this particular Toshiba having problems playing with it, as being the reason.

    Anyone else have this problem or know what the issue is? Should I invest in a better Player or is this Toshiba I have considered a really good player? Any info/help would be appreciated.
     
  2. AnthonyC

    AnthonyC Cinematographer

    Joined:
    Mar 29, 2004
    Messages:
    2,342
    Likes Received:
    0
    I have no pixelation issues but the commentary refuses to play on my copy. Tried it on the computer too, so it shouldn't be a player issue.
     
  3. Bill GrandPre

    Bill GrandPre Cinematographer

    Joined:
    Jun 9, 2001
    Messages:
    2,068
    Likes Received:
    1
    No problems on mine, not with regular playback, not with the commentarys, it plays fine.
     
  4. Brandon.B

    Brandon.B Stunt Coordinator

    Joined:
    Oct 26, 2005
    Messages:
    125
    Likes Received:
    0
    Ok, weird. My commentary works great on mine, its just the pixilation at parts and the skipping like crazy at the chapter selections. Strange.

    Thanks, though [​IMG]
     

Share This Page