PE 250w plate amp into 3ohm load?

Discussion in 'Archived Threads 2001-2004' started by AlexKunec, Dec 14, 2002.

  1. AlexKunec

    AlexKunec Stunt Coordinator

    Mar 9, 2002
    Likes Received:
    Has anyone driven the PE amp into a 3ohm load?
    I was thinking about doing this butI thought I should check what you guys say first.
  2. Geoff L

    Geoff L Screenwriter

    Dec 9, 2000
    Likes Received:
    Speaking to the PE amp 250, yes they will, BUT when pushed hard will shut down!

    My situation.
    I had 2-PE 300-794 amped sealed subs, each driving a (3.2-ohm load).. One amp was ok, and only shut down once the whole time it was in that cabinet driving that 3.2-ohm load.
    But the other when pushed hard for longer periods of time would shut down. Movies with short burts at loud volumes were "usually" ok, but music being pumped out hard or test sines & warbels for max output/extension would shut the other down. Longer section of big bass output, movies like the SW Pod Race would cause shut down if running them really loud.
    Well in my case very loud.:b

    To Reset:
    You have to turn the amp off then back on to get it to fire up again. It dose not reset itself. (At least mine didn't) They did run a bit warmer natural but not to point of being extremly HOT to touch.
    Just VERY warm when pushed hard for longer periods.

    This will void the PE warranty if you cook one, as 4-ohm is the min load they suggest/recommend. My amps where purchased almost 2-years ago and the 6-db boost at 30hz was changed to 2db around 20hz. They now ship with no boost I belive, or you can ask to have it added where you want for a small charge.
    (Correct me if Im wrong guys)

    I asked the same question 1-3/4 year or so ago and got no real straight responce except, ~{it was not recommended}~!

    So proceed with CAUTION....:wink:

  3. MichaelAngelo

    MichaelAngelo Stunt Coordinator

    Oct 22, 2002
    Likes Received:
    It *should* be OK. I've had mine running 2 ohm loads for almost 8 months now. 2 PE 250 watt amps, each driving a 2 ohm load, and no shut-offs-- but, I fan-cool mine.
    Geoff, thanks for the info on the shut-downs. Mine rarely get pushed hard, and I'm glad to know they'll shut off and not just melt!

Share This Page