Panasonic SA-HE200 Error Message!

Discussion in 'AV Receivers' started by Bob Lovallo, Feb 6, 2004.

  1. Bob Lovallo

    Bob Lovallo Extra

    Joined:
    Jun 4, 2003
    Messages:
    24
    Likes Received:
    0
    My 8 month old Panny SA-HE200 gives a message when I turn it on "F70"
    "Switch Off Power"

    Has anyone experienced this problem and any suggestions would be helpful!

    Thanks
     
  2. Thomas Willard

    Thomas Willard Stunt Coordinator

    Joined:
    Sep 15, 2003
    Messages:
    97
    Likes Received:
    0
    I had the same problem with my SA-HE100. Had purchased a warranty (which I rarely do) and took it in for repair. First time back analog input would work but not the digital. Took it back again and this time they could not fix it and gave me a new unit.

    When my F70 message appeared it was after I smelled something burning in the receiver. They replaced a capacitor the first time and what I smelled probably was the digital input board. Guess a replacement board was worth more than a new receiver.
     
  3. Bob Lovallo

    Bob Lovallo Extra

    Joined:
    Jun 4, 2003
    Messages:
    24
    Likes Received:
    0
    How long did each repair take? I hate to be without a receiver too long!

    Thanks,

    Bob
     
  4. Thomas Willard

    Thomas Willard Stunt Coordinator

    Joined:
    Sep 15, 2003
    Messages:
    97
    Likes Received:
    0
    I used the extended warranty offered by Circuit City. The repairs normally take 7-10 days. If they can't fix it the third time, they give you a refund for the receiver. On mine they gave up after the second try and I got the money I paid back. Bought the same model on sale and saved $20 on the deal.

    If you send yours back to Panasonic I don't know how long it will take. Most likely several weeks.
     
  5. Bob Lovallo

    Bob Lovallo Extra

    Joined:
    Jun 4, 2003
    Messages:
    24
    Likes Received:
    0
    Thanks for the help!

    Bob
     

Share This Page