1. Sign-up to become a member, and most of the ads you see will disappear. It only takes 30 seconds to sign up, so join the discussion today!
    Dismiss Notice

Oppo BDP 93 - No Output - HDMI Flashing on Front Display

Discussion in 'Playback Devices' started by Eastmancolor, Jul 17, 2016.

Tags:
  1. Eastmancolor

    Eastmancolor Second Unit

    Joined:
    Jan 26, 2012
    Messages:
    276
    Likes Received:
    367
    Trophy Points:
    110
    Location:
    Los Angeles, CA
    Real Name:
    Jim Harwood
    Just rewired with all new HDMI cables into a new Pioneer receiver. All has worked great for a week. Worked fine earlier today. Now, nothing.

    I am not getting any picture, nothing, when I try to watch Blu-ray's. Nothing comes up. Just get a blue screen. "HDMI" is flashing on the front display panel of my Oppo BDP 93.

    Checked the cables. All firmly in place.

    I must have hit something on the remote when I last used the player earlier today. I was in the setup screen briefly.

    Since I can't bring up the Oppo's setup screens on my TV, how can I check to see how the player is outputting a signal? Is there a button on the remote that I can press to reset the player?

    Anyone have any ideas? Thanks!
     
  2. Peter Apruzzese

    Peter Apruzzese Producer

    Joined:
    Dec 20, 1999
    Messages:
    4,078
    Likes Received:
    2,072
    Trophy Points:
    4,110
    Real Name:
    Peter Apruzzese
    Can you test the player by connecting it directly to the TV?
     

Share This Page