Oppo BDP-83 playback problem and mod kit problem

Discussion in 'Playback Devices' started by belfast, Jan 4, 2013.

  1. belfast

    belfast Auditioning

    Dec 20, 2011
    Likes Received:
    I recently got a used Oppo BDP-83, and it's now had two major problems. The first problem involves playback. Most discs play fine, but there are two titles that have frequent dropouts (i.e. the screen goes black for a fraction of a second, and often the sound goes too). FWIW, these titles are "Ladies & Gentlemen, the Rolling Stones" and Studio Canal's reissue of Godard's "Contempt." Neither title was listed by Oppo as a title that had issues with this player, and when I contacted them, they suggested it was a problem with the HDMI connection. I tried swapping out the HDMI cable with a new one (same model though) but that didn't change a thing. FWIW, the cable was an AmazonBasics High-Speed HDMI cable (max1.4 hdmi 3m). Here's the URL: http://www.amazon.com/AmazonBasics-High-Speed-HDMI-Cable-Meters/dp/B003L1ZYYW/ref=sr_1_1?ie=UTF8&qid=1347378790&sr=8-1&keywords=amazon+basics I never solved this problem, and went on to other things, namely acquiring a region free mod kit from ebay. The one I got involved a ribbon replacement, and it's this exact one: http://www.ebay.com/itm/150657714322;jsessionid=FBE9C20A5017C60773E81B1CE34E71EA?ru=http%3A%2F%2Fwww.ebay.com%2Fsch%2Fi.html%3F_sacat%3D0%26_from%3DR40%26_nkw%3D150657714322%26_rdc%3D1 At first, it seemed to work, but a few weeks later (during which time it was left as a Region A player), I tried changing the region to Region B, and even though the player still indeed beeps when you hit the blue button for 5 seconds, and even though it still beeps the appropriate number of times when you hit 1, 2 or 3, the region will not change. (This was made very obvious when I played a Region B disc that displayed a title card that stated "This disc will only play in Region B Blu-Ray players.") Is this common with mod kits? If it still does all the correct "beeping," has it become faulty or perhaps it wasn't connected properly, even though it did work temporarily? Any help would be greatly appreciated.
  2. AndyMcKinney

    AndyMcKinney Cinematographer

    Apr 2, 2004
    Likes Received:
    Kentucky, USA
    I think the "black screen" problem is a hardware-handshaking issue between your player and TV. I think I had a similar issue when I connected my brand-new BDP-83 to my brand-new Sharp LC60E88UN television. Did some searching and came across the "handshaking" thing. The fix was changing a menu setting, but I can't remember if the setting I changed was in the player or the TV. Have you tried un-installing and re-installing your mod? Maybe that will fix the other problem.

Share This Page