Onkyo SR503

Discussion in 'AV Receivers' started by Sunil*N, Apr 28, 2006.

  1. Sunil*N

    Sunil*N Extra

    Joined:
    Jan 4, 2006
    Messages:
    15
    Likes Received:
    0
    My Onkyo SR503 shuts off with in 2/3 seconds...the red light on the panel blinks. The receiver turn on for 2/3 seconds and goes off..

    has any one experinced something like this? I have used this for couple of months, currently 5.1 set up

    Thanks,

    Sunil
     
  2. Andrew Pratt

    Andrew Pratt Producer

    Joined:
    Dec 8, 1998
    Messages:
    3,806
    Likes Received:
    0
    Unplug all your speakers and try it again...it sounds like its shorting out somewhere so we need to find out if its a speaker or internal.
     
  3. Sunil*N

    Sunil*N Extra

    Joined:
    Jan 4, 2006
    Messages:
    15
    Likes Received:
    0
    umm...I did unplug speakers and tried...same deal...

    now I am getting a bad feeling about this...
     
  4. JeremyErwin

    JeremyErwin Producer

    Joined:
    Feb 11, 2001
    Messages:
    3,218
    Likes Received:
    0
    you can reset the settings by holding video-1 while powering up. It should respond with "clear" in the display. It is likely, however that you will have to follow the advice given in the manual-- namely "Contact your Onkyo dealer"
     
  5. Steve_Drake

    Steve_Drake Stunt Coordinator

    Joined:
    Dec 24, 2005
    Messages:
    80
    Likes Received:
    0
    that happened to me, but what happened was a beer tab had somehow lodged itself between the speaker terminals. check every connection, or pray for warrenty service.
     

Share This Page